I am trying to boot from USB so I can install a couple different Linux distros. I can enter the BIOS, but as soon as I enter the BIOS the keyboard lights switch off (Num Lock and Caps Lock) and I cannot use the keyboard to do anything in the BIOS or even exit or restart the PC using Ctrl+Alt+Del or do anything at all with the keyboard.

But as soon as I boot back into Windows, everything is fine...

I've never had this problem before and some Googling hasn't helped. I've tried using a few other keyboards and simply unplugging/replugging the keyboards, but it didn't work.

Is there anything I can do in Windows to maybe find out why the keyboard isn't working in the BIOS screen?

In the Device Manager, all the drivers are up to date and there are no conflicts.


try using non usb keyboard, one with PS/2 connector.


Plug in a PS/2 keyboard. You can then change the setting in the BIOS to enable USB support for the mouse and keyboard. You can then use your other keyboard. If you do not have a PS/2 keyboard lying around, get a USB to PS/2 converter plug it into the PS/2 port. This will help you get to the settings in the BIOS.

  • PS/2 keyboard? It's been a long time since I've had one of those. I think they're the ones with the round things at the end, right? If so... I'm outa luck cause this new machine doesn't support those. – uSeRnAmEhAhAhAhAhA Nov 11 '13 at 10:36

Try using the keyboard that came with the machine (assuming it's a consumer machine). I know a number a of large name brand manufacturers will not support third party or wireless USB keyboards from BIOS screens. But the BIOS will accept input from the branded wired USB keyboards.

  • Thank you Scott. I would have used it but that keyboard was faulty (and felt weird to use) so I threw it out. I did however manage to solve this problem. It appears that USB ports at the back of this computer are given higher priority over the ones on the side. I plugged the keyboard into the back of the PC (it's an AiO) and it worked in BIOS just fine. :-) – uSeRnAmEhAhAhAhAhA Nov 12 '13 at 10:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.