0

I upgrade my Ubuntu desktop to 13.10. When I say upgrade I mean installed on a new partition from scratch (old partition is available if

To the problem: I'm trying to ping a host (Drobo-FS server) by it's host name. I get "Unknown Host". However pinging from another computer on the same lan - works fine (a laptop with 12.04 lts).

for that matter every ping from the 13.10 to the local lan by hostname fails, ping with ip works.

I don't have a local DNS server but somehow all the other computers in the network find each other by host name - only this new one fails...

help appreciated...

1

As i see it now the problem is you're not getting a search domain from your dns-server (presumably your router).

Your resolv.conf should look like this:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8) 
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN 
nameserver 192.168.1.254         # <-- could also be 127.0.1.1, does not matter
search fritz.box                 # <-- THIS IS IMPORTANT

Normally with a ping the OS appends the search-string after the hostname to search on its internal network. (You'll see that ping drobo-fs.domain.ext does work.) You should have gotten the domain.ext automatically from the dns-server.

Now you'll need to determine what the domain.ext is in your case. You could try nslookup x.x.x.x where x.x.x.x is your dns-server (router?, in my example 192.168.1.254). For me it gave a name = fritz.box. at the end. (where fritz.box is the domain.ext)

Now you can add this yourself by adding it in the connection-settings like this:

http://i.imgur.com/5yMb12j.png

After that both ping drobo-fs.domain.ext and ping drobo-fs should work.


Old answer (for reference):

Why not just have the line hosts: files dns in your /etc/nsswitch.conf ?

Remove the mdns4_minimal [NOTFOUND=return] and mdns4 if you don't have a working mdns-setup in your network.

You could also try [NOTFOUND=continue] instead of [NOTFOUND=return] if you do have a mdns-setup in your network.

  • it is /etc/nsswitch.conf. edited my question. After updating the file - what services should I restart? – DrorCohen Nov 11 '13 at 20:50
  • That depends on what service exactly is using this file. Normally the file is read again but if some service has it in memory then a reboot is required. (or you need to know the service) See here – Rik Nov 11 '13 at 20:57
  • OK. Changed the file. Rebooted. Still doens't work. – DrorCohen Nov 11 '13 at 20:59
  • Ok. Do you have a search lan line in your resolv.conf? Try putting a # before it (just for testing). No reboot necessary. – Rik Nov 11 '13 at 21:06
  • this is my resolv.conf:# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8) # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN nameserver 127.0.1.1 – DrorCohen Nov 11 '13 at 21:13
0

Having wins in /etc/nsswitch.conf should work. I know it works on my network where we run a wins. But if the entry you are looking for is not in wins, then of course it wouldn't work. So, "wins" is the right answer, now you just need to make sure the client is in wins.

  • pinging from my laptop works... and pinging from the previous installation also worked... and the host does answer to the smbclient -L command. So I think it should work as well from the new isntallation – DrorCohen Nov 11 '13 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.