0

I have a Linksys router and a Belkin wireless router at home. The Linksys router is connected to cable modem and two computers, as well as to the Belkin wireless router.

A 3rd computer is connected to the Belkin router through Wifi.

The IP addresses of the computers connected to Linksys are 192.168.1.101 and 192.168.1.102. The IP address of the Linksys router on LAN is 192.168.1.1.

The IP address of the Belkin wireless router is 192.168.2.1(based on the 3rd computer's routing table) and the IP address of the 3rd computer is 192.168.2.5.

If I ping 192.168.1.101 from 192.168.2.5, all are well. However, if I ping 192.168.2.5 from 192.168.1.101, Destination Host Unreachable.

Why?

1

that would be because the default gateway on your 192.168.1.101 machine is 192.168.1.1. So when you ask to send traffic to a network that your not on directly it sends it to the default gateway which in this case is 192.168.1.1. So the problem is that 192.168.1.1 doesn't know how to get to 192.168.2.0/24 network.

If the Belkin is connected to the Linksys it should also have a 192.168.1.x address? Once u know this you could fix this 1 of 2 ways. Add a static route on 192.168.1.1 that says to get to destination network 192.168.2.0/24 the Gateway or next hop is 192.168.1.x(belkin). You should be able to add this somewhere in the Linksys gui. Look for "routing" in the menus. The other option is to just add a static route to Windows on your 192.168.1.101 box.

route add 192.168.2.0 MASK 255.255.255.0 192.168.1.x

Hope this helps.

  • how can i find out the 192.168.1.x address for belkin router. It is connected to Linksys with a static ip 192.168.2.1. DHCP on belkin is turned on – windchime Nov 13 '13 at 2:51
  • Im thinking that the 2.1 address would be for the wifi interface of the belkin. is that right? In the belkins web gui it should have wifi and lan interfaces listed somewhere. Im assuming that the belkin might have 4 lan ports and youve connected one of those to one of the the linksys lan ports? – PeterJ Nov 13 '13 at 6:09
  • yes. I found out. Belkin's WAN IP is 192.168.1.100 and LAN IP is 192.168.2.1. I still can not ping 192.168.1.100 from 192.168.1.101. In routing table, the entry for 192.168.1.0 is like: 192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth2 – windchime Nov 13 '13 at 17:28
  • You need at least one route on the Linksys router. 192.168.2.1 255.255.255.0 Needs to be sent out the port for the Belkin router (eth2, eth3 whatever it is) There may be a second route listed, something to the affect of 0.0.0.0 0.0.0.0 (Interface) just ignore that. That is where the linksys goes if it cant find a related entry in it's table elsewhere (thats probably where it has been trying to find you 2.X network at) Once you have a route for 192.168.2.X out the interface that goes to the belkin, try again. Also IF the issue persists, provide us model numbers so we can give better direction – PsychoData Nov 22 '13 at 20:21
0

You have what we in the networking business call a "black hole". Basically you can ping from the 2.x network to 1.x because the 2.x computer asks the belkin router (the computers gateway to the outside world), the belkin router might know, but is probably going to try and arp to find the 1.x computer address. The computer responds to the belkin router, which then forwards back to the 2.x computer.

The other direction the 1.x computer asks the linksys router where it is and (unless you have set up a route to 192.168.2.0/24 network if the router supports it) the linksys router has no idea. Now a 192.168.2.x address is a private class C (which can't be routed accross the internet) So the linksys router might just give up then, or it might try to send it up the chain (the linksys router asking ITs gatweway) at some point they are going to stop trying to resolve the private address and return back destination unreachable.

Perhaps you installed the belkin router solely as a way to isolate the wireless clients, not a bad practivce, You're either going to need to add the route from the linksys router to the 2.x network (may not even be supported on home devices without custom firmware) you would also need to make sure that NAT is disabled on the belkin router.

To have the networks talking directly (not seperate networks) , you are going to need to do a few things. Change the way that the belkin is connected. You're probably in the WAN/Uplink/Trunk/Modem ports on the belkin, change that to on of the regular/LAN/Downstream ports. You would also need to turn off the DHCP server (or configure it as a relay) and change your address on the belkin to the same range as the linksys (I'd suggested belkin is 1.2 since linksys is 1.1) This woulld allow traffic to still be resolved through the linksys router, DHCP is handled by linksys, belkin may be a wireless AP, but DHCP should still be through linksys for the wireless clients. Basically we changed belkin from being a SUB network to an Access point and switch on the same network.

  • Belkin router has a modem port and 4 LAN ports. I connected belkin's modem port to one of Linksys's LAN port. I tried to change Belkin's IP to static 192.168.1.2 and disable DHCP. It stopped working all together. No response to pinging. – windchime Nov 13 '13 at 3:21
  • You're in the wrong port. the "Modem" port is saying that you going upstream out that port to the modem. You need to connect to one of the four LAN ports. – PsychoData Nov 13 '13 at 17:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.