I have just got a new iMac 14.3 with 21.5' display. It has Intel i7 processor and NVIDIA GeForce GT750M graphics card with GPU (Device ID: 0x00fe9). I have installed Ubuntu 13.10 on it (dual boot with refit). Everything works fine apart from graphics. It is clear that graphics' not accelerated, and there are no drivers suggested in the "Additional drivers" section. I have tried to

  1. Install nvidia drivers from the repository.
  2. Download nvidia drivers and install them manually.
  3. Follow instructions here.
  4. Follow instructions here.
  5. Follow instructions here.
  6. Install bumblebee.
  7. Play around with xorg.conf file.
  8. Blacklist nouveau.

As you may guess, nothing worked. The weirdest thing is, that when I boot from a LiveCD, it picks up screen resolution and all the rest correctly, though when I install the system to my Hard Drive it clearly does not have proper drivers. Does anyone have any suggestion what to do?

  • Have you verified the current drivers even supports your mobile card? – Ramhound Nov 12 '13 at 16:56
  • Yes, and I have downloaded the correct file from the official website – Eugene B Nov 12 '13 at 17:08
  • Thats not exactly what I asked. I asked if the drivers supports your card. I have no doubt they do but always good to verify. – Ramhound Nov 12 '13 at 17:23
  • ehm, if you can suggest a way to check it with 100% guarantee... I'm pretty sure I've downloaded the correct drivers when I've downloaded them, but it'd be nice to have an answer for your question for nvidia-current as well. – Eugene B Nov 12 '13 at 18:03
  • The supported products are listed on the download website for the file and in the release notes. – Ramhound Nov 12 '13 at 18:09

The solution is actually very simple: just boot with nolapic instead of acpi=off.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.