I just got cable internet installed (Comcast). It claims that my down speed should be 25mbit. Over wifi, I get close to that on my laptop, but only about 8 on average with my iPhone/iPad.

I'm using testmy.net in the browser on all devices. I have an ARRIS / Motorola SurfBoard SB6141 DOCSIS 3.0 Cable Modem and a Medialink Wireless N Broadband Router. iPhone 5 and iPad 2.

I read somewhere that disabling WMM and the firewall on the router would help (is this even a safe idea?). I've tried both, and neither seem to make much of a difference, if any at all (sidebar: I've noticed that my download speeds vary wildly with cable internet... on my laptop, I'll get 12 down, then 22 five minutes later. Is this typical for cable internet?).

  • 1
    Which iPhone / iPad do you have? – sgtbeano Nov 13 '13 at 15:57
  • Also, have you seen this thread? discussions.apple.com/message/15065064#15065064 – sgtbeano Nov 13 '13 at 15:59
  • And there's no inherent danger in turning off WMM or QoS as described in the Apple discussion. However it may affect other devices on your network such as streaming boxes etc. – sgtbeano Nov 13 '13 at 16:02
  • @sgtbeano Question edited with iPhone 5 and iPad 2... thanks for pointing out that omission. – Sam Nov 13 '13 at 16:03
  • 1
    Lots of people on the apple discussion mentioning the iPad 2 - I'm almost all the way through it now but turning off WMM and QoS seems to be helping a lot, as well as turning off multiple mode too i.e. n rather than a/b/g/n etc. This page discussions.apple.com/thread/2398063?start=150&tstart=0 has a good post on checking channel space on your wireless too. – sgtbeano Nov 13 '13 at 16:29

It's the Comcast router, don't change your Apple settings! Turn off your personal router. Using a pen, press the reset button on the top of the back of your Comcast box and hold for a FULL 30 slow count seconds. Let go and allow the router to reboot, say at least 5 minutes. Go watch TV for a while, don't rush this step! Come back and turn on your personal router. All fixed!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.