Seems to be driver problems with Intel USB 3.0 extensible Host Controller. I've done everything short of re installing windows so far. I've re installed all drivers.

Here is where it gets weird. If I "cold boot" from completely powered off all the drivers load fine. However, if I restart the mouse and keyboard don't work once windows boots (mouse and keyboard do work during bios etc).

  • 1
    More information about the BIOS settings is required. Have you tried to update/reset your bios configuration. When I had a problem similar to this upgrading my bios resolved it – Ramhound Nov 14 '13 at 1:13
  • Yes I've reset my BIOS. I haven't upgraded the BIOS just yet. – Grant Nov 14 '13 at 5:00
  • 1
    Come back when you try that. – Ramhound Nov 14 '13 at 11:57
  • @Ramhound Updating the BIOS did indeed fix it. I'm always hesitant about updating BIOS. Thanks for your help. – Grant Nov 14 '13 at 23:44
  • Post that your solution as an answer. Mention the motherboard, the revision you had, and the revision you upgraded to. I am going to guess you have a Haswell motherboard ( because of the fact I had a very similar problem ). Although in my case it was random. – Ramhound Nov 15 '13 at 0:55

Work PC Setup: Win 7 Ultimate 64bit Core i7 4470k MSI Z87M-G43 Samsung 840 SSD (250GB) Intel HD Graphics 4600

Initially the BIOS version was at v2.20 updating to v2.40 fixed my problems with USB 3.0 and the start up problems. I used MSI's Live Update software http://us.msi.com/service/Live-Update-5-Manual/ to update via Windows as I had problems with MFlash via BIOS.

After a restart everything worked fine and as expected. I'd recommend let MSI's live update run all the necessary updates.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.