I was running Ubuntu 8.x on my desktop and everything worked fine. I'm using wired internet and it worked perfectly, pages loaded pretty fast.

However, when I decided to upgrade to 9.10 the upgrade failed at some point, however I was left with what appeared to be Ubuntu 9.10. Since then the internet has been weird. When I go to a website it takes at least 10 seconds for the page to display, however if I'm on a site and navigate to other pages on the website it loads quickly. This never happened prior to the upgrade.

I thought this may be due to the upgrade not installing correctly so I did a fresh install of Xubuntu 9.10 but the problems are still the same.

I'm writing this on a Vista machine over the wireless network and internet is fine. Does anyone have any ideas of the issue and whether this is a issue of the latest Ubuntu/Xubuntu/Kubuntu editions?

closed as too localized by Sathyajith Bhat Sep 1 '11 at 4:51

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.


This is not an issue in the lastest Ubuntu. I'm writing this on 9.10 and everything works nicely.

What you seem to experience is a DNS problem. You should check which DNS servers your machine is using and make sure that they are the ones that your ISP is using. Obviously you are running into some kind of timeout.


Sorry for the cross-post, but I thought it might be helpful. Also, the question seems to be a double post, as well ... :)

Your problem does not seem to be a problem of (K)Ubuntu, but of your router or ISP (see Launchpad for a looong bug report). Therefore, I advise you to not disable IPv6. While this might help in short term, he problem will probably hunt you down again in one or two years when IPv6 takes over from IPv4.

The first thing you should try is updating your router's firmware. This completely solved the problem for me (and others). If this doesn't help, you should bug either your ISP or the router's manufacturer until they fix things.


What hardware are you running this on?

I found FireFox 3.x often paused noticeably (though not for as much as ten seconds) on visiting new sites on my netbook (with its slow SSD) due to updating the sqlite file that feeds the bad site checking process. This was introduced in FF3, so may not have been present in your Ubuntu 8.x installation.

To see if disk I/O is the bottle-neck you are seeing, run top in a console window and see what the %wait reading is during these pauses. Also, you ca try iotop to confirm that any big group of I/O operations you see is indeed directly due to FireFox.

On my netbook, which has more RAM than it needs for day-to-day operation, I got around this issue by moving my FireFox profile to a RAM drive (and syncing it back to the copy on the SSD occasionally, when I've made changes like updating bookmarks or addins). I'm still using FF3.x, not the 3.5.x that comes with Ubuntu 9.10, so I can't say for sure if this behaviour would be the same on the newer version.