I have a puzzle for you; I've been banging my head against the wall for the past week trying to figure this out, and I just have no idea what it could possibly be. If you can figure it out I will give you many, many Internet cookies.


Two USB Keyboards (specifically: Razer Blackwidow Ultimate and Ducky Shiny Zero) disconnect/reconnect at least once every 5 minutes when plugged into my desktop.

Troubleshooting things tried

  • Bought a new keyboard
  • Tried uninstalling/reinstalling keyboard drivers
  • Tried uninstalling/reinstalling Windows
  • Tried unchecking all the boxes in Device Manager that allows Windows to turn off this USB device to save power
  • Tried using every single USB slot on my computer
  • Tried unplugging every other USB device except my keyboard

Interesting facts

  • Cheap, wireless Logitech keyboard does NOT flicker when plugged into my desktop.
  • Razer Blackwidow does NOT flicker when plugged into my laptop (which is running Ubuntu)
  • No other USB devices have this flickering problem on my desktop
  • I've had my box and Razer Blackwidow for quite a few years. This only recently (past week or so) started being a big problem.

System specs

  • OS: Win 7 Home Premium 64 bit (also flickers in Win 7 Pro SP2 64 bit)
  • Processor: Intel Core i5-3470 @ 3.20 GHz
  • Mobo: ASUS P8H61-M LE/CSM Rev x.0x
  • RAM: 4 GB
  • PSU: ATX 12V V2.3, AC input (110-120/220-240v~), DC output (3.3v/5v+), Max output (120w 276w)

Things I don't think it is

  • Mobo short - the Logitech keyboard should also flicker
  • Keyboard short - both keyboard would have to have a short, and they should also flicker on my laptop

My current running theory is that both keyboards are trying to pull too much power which causes the USB hub to reset, which would make the keyboard think it's being disconnected/reconnected. The cheap Logitech keyboard, which isn't trying to poll at 1000, does not pull too much power and thus stays connected.

  • You think your desktop couldn't handle as much power on usb as your laptop? You could try running a Ubuntu LiveCD on the desktop to see if the USB-hub resets too. (I take it you mean by USB-hub the internal one. You don't use an external hub, do you?) – Rik Nov 14 '13 at 21:39
  • And is that USB3 or USB2 on board in the desktop. See here a similar problem. – Rik Nov 14 '13 at 21:43
  • @Rik Yes, I'm using internal USB hubs. They're plugged into USB2 ports. I'll have to try testing it using an Ubuntu-live cd. Also, I too am using an ASUS mobo, dunno how I forgot to put that in my system specs. Hm... – user274163 Nov 14 '13 at 21:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.