I'm wanting to install softwares. I'm on Windows 7 Home Premium 64-bit. I have tried:

  • Turning off the User Access Control (UAC)
  • Right click and Run as Administrator
  • Run installer in compatibility mode (Windows XP SP3 and Windows Vista SP2)
  • Give permission to all temporary folders available (C:\Users\User\AppData\Local\Temp and C:\Windows\Temp)
  • Relocate the temporary folder to C:\temp and give it the permission
  • Take control of temporary folders
  • Creating a new administrator account and installing from that account
  • Checking the registry in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SQMClient\Windows\DisabledSession (there's nothing there though)
  • Running MalwareBytes and scan for suspicious files that may block the installing process.

But, still, it hasn't been successful. The Access is denied warning always appears and gives me a lot of headaches. I can't install anything. Any help? :/

  • Please add the detail of the installation source location, i.e. a DVD, a specific folder, "downloads", ?? and also at least one example of software you're trying to install. – Debra Nov 16 '13 at 4:33
  • @Debra The installation location varies; sometimes it's from a DVD, sometimes it's from an USB drive, sometimes it's from Downloads, etc. Most from Downloads though. Some example are node.js and Audacity. – deathlock Nov 17 '13 at 13:13
  • The only way for me to install software is to download/use the packaged .zip version of the installation, like I did when installing Audacity. But not all software installation comes with .zip, and that's frustrating. :/ – deathlock Nov 17 '13 at 13:15
  • Have you tried simply logging in as Administrator? It sounds as if the login you're using doesn't have rights to the temp folder. Go to a cmd prompt (run "cmd.exe") and type the word "SET", and see what TMP and TEMP are set to. Also, what do you mean by "relocate the temp folder"? I'd really suggest you modify your answer to add the quote of the error (instead of just in subject), as well as to list some examples of the install process you're doing, including if you are trying to run an MSI file or run a specific command, and specifically when the error comes up, etc. – Debra Nov 17 '13 at 15:27
  • Also, if this computer is on a domain, please say so ... and have you checked time sync to be sure your computer is at the right date & time? – Debra Nov 17 '13 at 15:31

I'd tried everything. Nothing helped. But then I did close the Avast antivirus, the firewall and the spybut (malware) and that helped. Think I first tried to close antivirus and the firewall and that didn't help. So I believe it was the spybut or some combination.

  • Some antivirus/antimalware software block execution of applications in known temporary folders. This prevents users from accidentally running a virus downloaded from the internet. This should be configurable from within the application. – Keltari Apr 7 '14 at 17:16

I had the exact same problem as you did and did all the same steps but nothing worked. Until I checked my antivirus and firewall settings. I already had my firewall shutdown, yet I noticed there was some parts still running in the background as prosesses. So I decided to open my firewall and check the settings (im using Comodo firewall), I forgot I had HIPS - setting as "Safe mode". I changed it to "Disabled" and now everything works like a charm again. Not sure if this helps anyone but it helped me in the end.

  • Smokereign

Answer is I use Comodo and it was turned off - seems the system relies on Comodo to allow stuff to run. Once turned back on, I allowed the install when Comodo popup asked and then it worked :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.