I got Windows 8.1 Pro a few days ago and tried to enable lock screen slideshow. However, trying every combination of options in the lock screen page, I am still unable to see a slideshow.

As you can see, my settings page does not include "Let Windows choose pictures for my slide show". My lock screen also doesn't extend to my right monitor. This is in contrast to the options shown on common tutorials on the net. I can also assure you that there are images in the Desktoppr folder, which is used for a slideshow desktop background.

Lock screen settings

  • 1
    i'd like to mention the same problem happen in windows-10 – draeron Aug 18 '15 at 15:11

Apparently the slideshow has dependencies.

When I enabled the service "Windows Search" it began to work again.

  • 1
    Had the same problem as the original poster with Windows 8/8.1 (don't remember exactly which edition the feature arrived with), after upgrading to Windows 10, it persisted. The November update did not fix this and now, after the Anniversary update, the problem is still present. The Search service is running, folder contains only images, have performed serveral sfc scans but nothing seems to be working and debugging clues are few and far between... :( – Manjabes Aug 4 '16 at 19:28

I don't think this is an issue with the slideshow itself exactly, I think it is more to do with windows not seeing any images that it can use for the slideshow.

If it was me, I would do the following:

  1. Make a folder called "testslide" (or whatever)
  2. Put 3 or 4 images into it
  3. Choose Add a folder from your screenshot screen.
  4. Find this "testslide" folder.... does windows show you images here?
  5. Pick Choose this folder
  6. See if the message You need more than one picture to show in your slide show has gone.

At this point, either a) everything is now working - make a folder with the images you want. b) your images are not suitable for some reason.. try images with a different extension (bmp, jpg, etc) OR c) something is not right with your windows install - but I don't think this is the case.

  • I was able to get it to work with a new folder and new images (of trees). I was not the multi-pane slideshow that I've seen on videos, though. I also tried segregating my images by type, but to no avail. They are all 1080+. These are the images if you want to take a look. Also note when I mix even one of them with the tree images it stops working, and then the whole folder seems to be corrupted so I have to move them to a new folder. All very strange. – Caleb Jares Nov 20 '13 at 6:51
  • possible answer - the lock screen slideshow will only work when a user is logged in. If you are looking at the lock screen either before logging in or after logging out, you will only get a single image showing. (you need to lock your screen 'WINDOWS KEY + L' whilst you are logged in). Also, by default, if you are on a laptop, the slideshow will "pause" when running on battery to save power - showing a single image only. – Mark Nov 20 '13 at 23:02
  • Nice try Mark. Unfortunately I'm not on a laptop and I have been testing by locking my computer after being logged in. I'm still confused as to why I don't get multi-pane slideshows like other users (and why my settings screen is different). – Caleb Jares Nov 21 '13 at 5:22
  • What file-types are the images? – tumchaaditya Nov 22 '13 at 17:34
  • ok - in that case, I am opting for option c. I think that somewhere, your installation of 8.1 has gone a bit skew-whiff. Try refreshing your pc (all your files remain, but all apps and some programs will need to be re-installed, and if that doesn't work, do a full reset of your pc after backing everything up. I'll put money on it that it will work properly after that. – Mark Nov 22 '13 at 23:02

I finally figured it out why it did not work for me in either 8.1 or 10 - the folder that I was trying to use had this property unselected:

Enable indexing

When selecting that checkbox AND having the Windows Search service running, the feature started working. Better late than never, hope this helps somebody.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.