0

I use Iceweasel 17.0.9 on Debian Testing (Jessie).

When I visit https://addons.mozilla.org/en-US/firefox/addon/vimperator/contribute/roadblock/?src=dp-btn-primary&version=3.8 and try to install Vimperator 3.8, I get this error:

Vimperator could not be installed because it is not compatible with Iceweasel 17.0.9

How can I install Vimperator on Iceweasel 17.0.9?

2
  • I noted there is the word Testing in the title I'm not familiar with the software package so not 100% sure if it's applicable but just wanted to remind you "Questions about bugs in pre-release/beta software or prototype hardware are off-topic"
    – 50-3
    Nov 17, 2013 at 11:51
  • @50-3 Thanks. This question is not about a bug. It's a question about why a stable version of Vimperator doesn't install on a stable version of Iceweasel or Firefox, although the operating system I am using is not stable yet.
    – Susam Pal
    Nov 17, 2013 at 11:57

1 Answer 1

0

Quick solution

Install Vimperator 3.7.1 instead of Vimperator 3.8. Go to https://addons.mozilla.org/en-US/firefox/addon/vimperator/contribute/roadblock/?src=version-history&version=3.7.1 and click 'Add to Firefox' button.

Long solution

This is same as the previous solution. The steps below document how you can reach the URL mentioned in the previous solution from the Vimperator addon page in a step by step manner.

  1. Go to https://addons.mozilla.org/en-US/firefox/addon/vimperator/
  2. Scroll down to 'Version information' section. Click on this section.
  3. At the bottom of this section, click on 'See complete version history' link. You'll land on https://addons.mozilla.org/en-US/firefox/addon/vimperator/versions/.
  4. Scroll down to 'Version 3.7.1' section and click on 'Continue to download'. You'll land on https://addons.mozilla.org/en-US/firefox/addon/vimperator/contribute/roadblock/?src=version-history&version=3.7.1.
  5. Click 'Add to Firefox' button.

Why does Version 3.7.1 work but Version 3.8 doesn't?

Visit https://addons.mozilla.org/en-US/firefox/addon/vimperator/versions/. Scroll down to Version 3.8, then click "View source" link below it. The install.rdf file of Vimperator 3.8 shows that Vimperator 3.8 can be installed on Iceweasel/Firefox versions 20.0-26.0.

<em:targetApplication>
    <Description>
        <em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
        <em:minVersion>20.0</em:minVersion>
        <em:maxVersion>26.0</em:maxVersion>
    </Description>
</em:targetApplication>

Now visit https://addons.mozilla.org/en-US/firefox/addon/vimperator/versions/ and scroll down to Version 3.7.1, then click "View source" link below it. The install.rdf file of Vimperator 3.7.1 shows that it can be installed on Iceweasel/Firefox versions 17.0-23.0.

<em:targetApplication>
    <Description>
        <em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
        <em:minVersion>17.0</em:minVersion>
        <em:maxVersion>23.0</em:maxVersion>
    </Description>
</em:targetApplication>

Therefore, install Vimperator 3.7.1 from https://addons.mozilla.org/en-US/firefox/addon/vimperator/contribute/roadblock/?src=version-history&version=3.7.1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.