I enabled AHCI mode for SATA (and virtualisation) in my BIOS and rebooted to Windows 8. This failed, so I switched it back. I realise now that something like this is required to change to AHCI mode.

After switching back I am stuck at the "Please wait" screen forever. This happens after selecting Windows 8 from the graphical boot manager and before the login screen. Sometimes there seems to be a small amount of activity judging by the HDD light and sometimes quite a lot. Even after stopping there are sometimes large bouts of activity later on. I've tried leaving it overnight and throughout the day with no progress seemingly being made. Suspend and resume work properly.

Using various advanced boot options has also made no progress: automatic repair fails, safe mode fails, command prompt succeeds but SFC fails. There is no pending.xml. I've also tried using DISM to remove any pending operations, which fails. I have no system restore point. I've tried automatic repair from the DVD also. I've tried re-enabling AHCI mode after following these instructions.

UPDATE: I have just found that booting straight to the Windows disk (BIOS order) gives an error about \Boot\BCD (code: 0xc000000f) being missing or corrupted. Not convinced this is the case, as normally (via GRUB) the bootmgr is functional. Appears to be boot disk ordering issue, having used bcdboot to force boot files onto the drive, it boots again to "Please wait".

This is a multi-boot machine. The Windows XP installation and Ubuntu still work fine.

I would really prefer not to lose all applications and settings with a refresh install. Is there any way to debug this issue further?

UPDATE: out of desperation - and after several more hours trying fail-safe BIOS settings, DISM variations etc. - I tried the "Refresh your PC" option. It also fails with message "There was a problem refreshing your PC". It appears that Windows 8 provides absolutely no information whatsoever about what is wrong, and none of the supplied tools function properly to recover.

  • Try using the F8 options with Win8. Otherwise you are pretty much stuck. I would resize my partitions to get all the disk space I just can, or use Crashplan. And there goes the reinstall. – Shiki Nov 17 '13 at 16:15
  • As above, the advanced boot options have been no help thus far (and F8 does not work on Win8). I'm looking for something like a more verbose boot or log file to find out how to target repairs. I would not expect it to fail after switching back to IDE compatible mode. – Sam Brightman Nov 17 '13 at 16:26
  • "Would not expect it to fail." It's next-gen, son. Step it up. Those weather tiles are centuries ahead of our time. Even Shift+F8 fails? (I read that you only have a very small window to press it though.) – Shiki Nov 17 '13 at 16:36
  • Shift-F8 fails, but that isn't important. I can get to the advanced options and they do not help. – Sam Brightman Nov 17 '13 at 17:23
  • Please add to your post the detailed partitions status of the disk. Have you tried to : (1) Reset BIOS to defaults, (2) Mount the Windows 8 partition in Ubuntu and see if this gives any warnings? – harrymc Jan 25 '15 at 10:07

With great relief, I write this from a working Windows 8 installation (first time in more than a year - although adding the bounty was rather badly timed :S). I have lost my third-party apps which will need to be re-installed but most settings other than that are still intact.

In the end it was the Refresh Install from the Windows 8 DVD which got things working. This is strange, because I had already tried it multiple times from both the HD boot menu and the DVD media. Note that:

  1. there is a rather worrying visual bug that occurs after this succeeds which shows an extra boot menu entry.
  2. a list of uninstalled application is placed on the desktop, which eases the pain a little.
  3. a Windows.old folder is created with copies of what was removed but you only have 28 days to retrieve files from it.

As to why this worked for me on this occasion: it is not entirely clear. However, I had been using the sfc and dism tools again this morning in an attempt to find and repair corrupted system files. The only way I could get access to these tools was to run the Windows 8 DVD and go through to the command prompt from the troubleshooting options. All other methods of repair/reduced functionality boot were non-functional by this point.

Neither of these tools were able to complete successfully. However, sfc stores its logs in %windir%\Logs\CBS\CBS.log and here I found references to the cbscore.dll being corrupted:

CBS Failed to load Core DLL from path: C:\Windows\winsxs\amd64_microsoft-windows-servicingstack_31bf3856ad364e35_6.2.9200.16613_none_06552205987959ac\cbscore.dll [HRESULT = 0x800700c1 - ERROR_BAD_EXE_FORMAT]

I then found this thread, which mentions the same message and changing the CBS version to an older one in the registry at HKLM\Software\Microsoft\Windows\CurrentVersion\Component Based Servicing\Version. I did dir /od %windir%\winsxs\*servicingstack* and found that there was a new version installed with a lower version number around the date that I started to have problems.

I ran regedit and loaded the offline hive from %windir%\System32\config\software into a temporary key. I changed both the key name and its value to be the same as the previous version I saw in the directory and unloaded the hive. At this point I retried:

sfc /scannow /offwindir=c:\windows /offbootdir=c:\

It got further but still did not complete successfully. I guessed that if the core of CBS was now functional, dism might be able to work properly. This page contains some useful information, and I ended up running:

dism /image:c:\ /cleanup-image /restorehealth /scratchdir:c:\windows\temp /loglevel:4

This also made more progress but ultimately failed due to not being able to find files to replace the corruption (the log file can be found at %windir%\Logs\DISM\dism.log). I did not know about the /source flag at this stage so perhaps appending /source:x:\sources\winsxs could have fixed things. Instead I decided to start retrying the automated repair steps from the DVD menus, which has got me to where I am - full boot!

I can't say for sure what finally helped but refresh install previously did not work so something I did this morning got it to work.

I have created a system restore point and plan to install all updates before creating another one. At that point I can retry AHCI mode with the proper preparation and begin re-installing apps.

  • I was NEVER able to get AHCI to work with windows 8 without a fresh install. I tried on a few different computers, all the same result regardless of what Microsoft says. I would say don't tempt fate unless you're prepared to start from scratch and switch to AHCI before the new install. – Foosh Jan 27 '15 at 23:04
  • You've tried the two methods that I linked in my question? – Sam Brightman Jan 28 '15 at 7:24
  • Oh yes, and then some. Even tried poking around on the disk with a linux live cd to check the partition, boot, and file information. Not saying it won't work for you, just that you should proceed with caution as always when poking around in the lower levels of your system. – Foosh Jan 28 '15 at 19:31
  • I tried turning on AHCI again with Windows 8 set to boot in safe mode and the registry changes from the answer linked in my question. Safe mode booted successfully, so I restarted in normal mode. Works fine. – Sam Brightman Apr 25 '15 at 11:37

Having got this working once I foolishly started messing around with my second SATA controller. This also caused an unrecoverable boot failure (although no indefinite Please Wait screen).

This time the fix was substantially easier: I already knew AHCI mode was working, so I left it in this mode and used Start-up Repair from the boot Troubleshoot->Advanced Options menu. Required a couple of reboots before automatic repair started, failed and offered the other options.

Adding this as another potential answer as it is unlikely I tried fixing it in AHCI mode the first time.


This bug/error can be circumvented by simply rotating your screen. Most likely your system is working 100% correct behind the "please wait" screen. What you need is to be able to launch the Task Manager and kill the process responsible.

Do the following steps:

  1. Hit Ctrl+Alt+ to rotate the screen 90 degrees, making the display area narrow.
  2. Restart.
  3. Hit Ctrl+Alt+ to return the screen orientation to normal. The "please wait" screen will now ocuppy only half of the screen size. You can now launch the Task Manager and operate it. I don't remember the name of the process (OptIn or something) but you will find it without doubt.

In case the Task Manager launches, but is entirely covered by the gray screen, do this:

  1. Make it active using Alt+Tab.
  2. Hit Alt+Space to bring up the window menu.
  3. Hit 4 times and then Enter to maximize Task Manager so that you can use it.
  • 1
    There is no such shortcut such as Ctrl-Alt-←. – kinokijuf Apr 13 '14 at 21:40
  • I remember some onboard Intel graphics do enable such shortcuts, but this seems sketchy... – Doktoro Reichard Apr 13 '14 at 21:47
  • Ah, apparently the screen-rotation shortcuts are available with nVidia cards. – Matt from VisionApp Apr 13 '14 at 21:52
  • I have an ATI card. I think the keys are available but not by default. Any ideas on how to test this without hotkeys? This sounds like it happens after the login screen, which I cannot reach. – Sam Brightman Apr 15 '14 at 5:45
  • I read somewhere else that you can connect an external monitor, thus extending the desktop a little to be able to use the task manager... – Matt from VisionApp Apr 15 '14 at 10:31

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.