43

An ad titled "Two friends who've never met" recently appeared on my girlfriend's Skype. The ad appears above the name of the contact she is currently speaking to and can't be disabled via the ad options build into Skype. How can we disable this ad?

The ad looks like this:

The problem

Things we have tried:

  • Tried unchecking "Help and Skype tips" and "Promotions" under "Alerts & messages" in the options menu.
  • Tried changing the language file per Primemover's answer here

B. Rename The English language file. Procedure listed below;

  1. Click Tools >> Change Language >> Edit Skype Language File...
  2. The Skype - Language File Editor window will open, click the Save As button
  3. Enter Standard English as filename , Save it on your desktop or in any folder you want.
  4. Click Tools >> Change Language >> Load Skype Language File..., then browse and select the Standard English language file.
  5. Restart Skype Again, this suggestion though proven to be working, is not from, suggested, or endorsed by Skype or any of its staff. So try at your own risk. This method should only be used, if and only if, those advertisements are seriously affecting your interest in using the Skype client.
  • Tried downgrading to Skype version 6.10, 6.9, 5.10, and 4.2

I can confirm that I've never seen ads like this before, nor have other contacts I've asked. Is there anything else we can try to disable this?

Note: This originally started on Skype 6.10 but has persisted across older versions upon downgrading.

Edit: How to disable the skype ads (advertisement)? fails to answer the question I have posted. This is not a duplicate. The question linked appears to target a different group of ads (promotions) and is unrelated.

18
  • 1
    Linking Close votes on a question that isn't off topic? for posterity. If anyone finds issue with this question, please explain your reasoning here. Nov 18, 2013 at 14:41
  • 1
    I know you said the answers to the other question did not solve your problem, but did you try upgrading to Premium as suggested by superuser.com/a/547815/6091 and skype.com/en/premium? Perhaps you also need to sign out and sign back in after upgrading to Premium.
    – rob
    Nov 18, 2013 at 19:57
  • @rob premium is kind of a last resort. I'll upgrade to it if I can find no other solution, otherwise I'd much rather a solution that doesn't require me to pay Microsoft to get rid of the ads. Nov 18, 2013 at 20:02
  • where does the advert direct when it is clicked on? Nov 19, 2013 at 9:05
  • 1
    @DavidSchwartz I reworded the initial paragraph so as not to offend your glaring discomfort with the psuedo-ambiguous. Please stop harassing me now. Nov 28, 2013 at 6:22

2 Answers 2

17

You could try editing your hosts file and pointing the offending ad's hostname to 127.0.0.1.

Edit the file %systemroot%\system32\drivers\etc\hosts

To the bottom of the file add the entry:

127.0.0.1 hostname-of-the-ad

Where hostname is the hostname of the ad. For example, if the ad's URL is http://www.some-ad-service.com/, you would use www.some-ad-service.com as the hostname (thanks slhck, for pointing this out).

Save the file.

Now whenever your machine attempts to access the ad's URL the request will be sent to your local machine instead. The end result being that the ad is blocked.

6
  • 4
    A hosts file does not take URLs. URLs are resource locators—the hosts file really just blocks hostnames.
    – slhck
    Nov 22, 2013 at 12:07
  • Yes, the hosts file assigns hostnames to IP addresses, but in this case the URL is the hostname that we want to assign. Nov 22, 2013 at 12:20
  • 1
    Well, it's not really. A hostname is part of the URL. A URL is only valid with a protocol scheme. I'm just saying it might be good to clarify your answer to mention that you cannot put http://example.com/some/ad.jpg in there, but only example.com. (It would also be interesting to know how to find where the ad is coming from.)
    – slhck
    Nov 22, 2013 at 12:24
  • 6
    127.0.0.1 rad.msn.com
    – FDisk
    Jan 14, 2014 at 9:38
  • 4
    Actually there is a site which holds a good example of hosts file someonewhocares.org/hosts it will bolck a lot of messy things in internet Jan 24, 2014 at 12:36
38

Extending off of Matt's answer, since he doesn't include possible hostnames to block.


You need to add entries to your hosts file, typically located here: C:\Windows\System32\drivers\etc\hosts

These are hostnames you'll want to block, by adding them to the hosts file:

127.0.0.1             sO.2mdn.net
127.0.0.1         static.2mdn.net
127.0.0.1            cdn.adnxs.com
127.0.0.1  cdn.adnxs.com.edgesuite.net
127.0.0.1     aka-cdn-ns.adtech.de
127.0.0.1            cdn.atdmt.com
127.0.0.1             ec.atdmt.com
127.0.0.1             ad.doubleclick.net
127.0.0.1        ad-emea.doubleclick.net
127.0.0.1         secure.flashtalking.com
127.0.0.1           ads1.msads.net
127.0.0.1           ads2.msads.net
127.0.0.1         a.ads2.msads.net
127.0.0.1         b.ads2.msads.net
127.0.0.1            ac3.msn.com
127.0.0.1           ads1.msn.com
127.0.0.1           flex.msn.com
127.0.0.1              g.msn.com
127.0.0.1            rad.msn.com
127.0.0.1      live.rads.msn.com
127.0.0.1        msntest.serving-sys.com
::1                   sO.2mdn.net
::1               static.2mdn.net
::1                  cdn.adnxs.com
::1        cdn.adnxs.com.edgesuite.net
::1           aka-cdn-ns.adtech.de
::1                  cdn.atdmt.com
::1                   ec.atdmt.com
::1                   ad.doubleclick.net
::1              ad-emea.doubleclick.net
::1               secure.flashtalking.com
::1                 ads1.msads.net
::1                 ads2.msads.net
::1               a.ads2.msads.net
::1               b.ads2.msads.net
::1                  ac3.msn.com
::1                 ads1.msn.com
::1                 flex.msn.com
::1                    g.msn.com
::1                  rad.msn.com
::1            live.rads.msn.com
::1              msntest.serving-sys.com     

Source of hostnames here: wikiHow, Skype forum, Skype forum #2, and a commenter Jason at Avangardo. Just a warning, but Microsoft Security Essentials (MSE) may think your hosts file was hijacked, so if you have issues make sure to allow the changes through MSE.

Also, you may need to restart your computer, in case flushing the dns cache doesn't work. It seems when you make a lot of changes to the hosts file Windows doesn't reload it.

On Skype 6.14 it re-enabled these options, you'll want to disable (uncheck) them: enter image description here enter image description here


A new method has emerged that works in Skype 6.13 and Skype 6.14, works on Windows using Internet Explorer settings, from Chris123NT:

Open up Control Panel > Internet Options.

enter image description here

Security > Restricted Sites > Sites

enter image description here

Type in https://apps.skype.com, and click Add.

enter image description here

Again, click Add, then Close, then OK. Now open up Skype, click on the home button, and hopefully the ad banner should disappear and not come back!

13
  • 1
    That's awesome! rad.msn.com is the only domain I've been able to locate until now. Jan 29, 2014 at 19:18
  • 2
    Thanks @leetNightshade, it's working so far. Let's hope Microsoft doesn't add more domains!
    – Churro
    Jan 30, 2014 at 21:36
  • 1
    Update: Nope. Ads are back. What other domains can we block?
    – Churro
    Jan 30, 2014 at 21:56
  • @Churro I think we might have to resort to blocking the ip address of the server? From looking at Process Explorer I got the feeling Skype was bypassing the domain name lookup. I even tried using PeerBlock in the hopes one of their ad lists would block them, to no avail; I also searched iblocklist.com. So, looks like we'll have to compile the list ourselves. This site is probably out of date, but could be used as reference: dslreports.com/forum/r27274447-Block-Ads-in-Skype I'll look into the issue this week. ProcMon will be useful in doing this, monitors all network traffic. Jan 30, 2014 at 22:00
  • 1
    Are you sure that wildcards are allowed in the Windows hosts file?
    – Arjan
    Apr 6, 2015 at 16:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.