I updated my OS X to Mavericks a while ago, and Google Chrome keeps crashing constantly.
I tried the following but none of them worked:

  • Cleared cache and cookies
  • Removed my user profile and added a user again
  • Disabled/Removed all extensions
  • Updated Chrome to latest version twice. 30 & 31.

This is the .crash file: https://dl.dropboxusercontent.com/u/16657557/Google%20Chrome_2013-11-18-202242_sallars-mac.crash

I can’t find the reason why it keeps crashing.
Can anyone help me with this? I searched a lot on google, nothing.


  • 1
    You could try to remove Chrome support files and reinstall Chrome.
    – Lri
    Nov 18, 2013 at 18:27
  • I have the exact same problem. Start this weekend. Chrome has become unusable now. I've temporarily switched to Safari. Nov 18, 2013 at 23:50

2 Answers 2


OS X 10.9.1 Update solved the problem.


I've managed to make it work finally with 10.9.1. Here is what I did:

  1. Launch a terminal window

    sudo rm /var/root/Library/LaunchAgents/com.google.keystone.agent.plist
    cd /Applications/Google\ Chrome
    sudo ./Google\ Chrome
  2. when Chome is running go to extensions, remove Google Docs.

  3. Quit Chrome
  4. Now Chrome should be able to run normally from the Finder

I hope it will also work for you guys

  • 2
    You definitely shouldn't start Chrome with sudo - there's no reason to do that. If you do, Chrome will write all new files during that session as root user.
    – Olli
    Jan 30, 2014 at 17:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .