Like already said in the title, a large set of applications is suddenly having massive memory leaks. These are all programms that I have use for some time already, and none of them had this problem before.

At first I only noticed it in Firefox. It was suddenly becoming unresponsive even though I had nothing opened aside it. I thought nothing of it untill a started a game (Crusader Kings II) which normaly loads in about a minute or two on my system, but it kept loading and loading. A quick look at the taskmanager told me that it was indeed doing something, slowly but surely allocating more and more memory. I killed it at 600 MB, because it was getting nowhere.

I think it is plausible for this game to hold so much memory, but it had merly finished the first loading step at that time and was still chewing on the second one after about two minutes. Same thing with a lot of other games from different publishers, so I think it is a system level problem. Maybe a corrupted system memory allocation rutine, maybe in some windows API or something? How would I identify such a problem?

Additional Information:

-Most progams don't seem to be affected by it, mostly games, especially all Paradox Interactive games and some others

-I am not sure that it is really a memory leak, as all affected programs are memory hungry and I don't know how much they actually need. However, if it is not a memory leak, it must be that the allocate memory too slowly, because a lot of programs have a noticably longer startup time (firefox sometimes even multiple minutes, windows media center a few seconds) or have sigificatly higher latency (CKII) even though the CPU usage is quite low

-Yes I know a lot of problems dissapear when you restart, but restarting was the first thing I did when CKII didn't start properly. Waiting one day and restarting today didn't fix anything either, thats why I am asking this

EDIT: System:

-Intel Core i5-3570K @ 3,8 GHz (so no overclocking issue)


-NVIDIA GeForce GTX 680

-Windows 7 64 bit

-Built by myself but fully functional more than a year, I don't suspect any problems here

  • I assume you have tried to apply all current updates? There isn't enough information to explain the behavior to be honest. Unused system memory is useless system memory. Have you updated ALL your drivers? – Ramhound Nov 18 '13 at 19:12

Could be malware. Or a badly written add-on. Can be hard to tell the difference sometimes.

I cannot point to a specific example right now, but I've read about programs that insert hooks (this is on Windows) to all other running programs. Sometimes this is for a good purpose, like accessibility tools that can convert all text to Braille or similar things.

Other times it is so that a botnet can steal your typed passwords.

So perhaps something else is running on your computer and inserting badly written, memory leaking code into all the other running programs.

You can try malware/spyware cleaner programs, or you can try reverting the system to a previous state. Or you can reinstall from scratch.


Malware, viruses, and other nasty stuff. It's allways good to do a scan. From my experience as a programmer, I found out that badly written games (in means like bad memory management) can fill your heap with tons of garbage. Ofcourse restarting might give an effect. Well the first few seconds and after that.. Well who knows..

Check you RAM and your HDD, might be something hardware-ish.

One thing that helped when I had a similar problem was to disassemble my whole computer (removed the cpu, removed the RAM and the GPU) waited for it to cool down then got the whole thing together and worked!

Other causes: (if you use air cooling) overheating, driver corruption, OS corruption.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.