1

I'm trying to mount an NTFS disk on Linux Mint. It seems windows wasn't done with this volume before it was turned off. Is there a way to fix this error without putting my drive in a windows machine?

Here is the error message

Error mounting /dev/sdb2 at /media/cobolt/Legalise it: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sdb2" "/media/cobolt/Legalise it"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0). Metadata kept in Windows cache, refused to mount. Failed to mount '/dev/sdb2': Operation not permitted The NTFS partition is in an unsafe state. Please resume and shutdown Windows fully (no hibernation or fast restarting), or mount the volume read-only with the 'ro' mount option.

  • 2
    Well-known problem, well-known solution. Read here: askubuntu.com/questions/145902/… – MariusMatutiae Nov 20 '13 at 10:27
  • Thank you for your response but it did not answer my question as it involves putting the drive in a windows computer which I can't do. – Cobolt Nov 20 '13 at 11:29
  • You did not read the whole answer... – MariusMatutiae Nov 20 '13 at 11:42
  • @MariusMatutiae in the OP's defense, the answer you linked to does not actually explain how to do this without booting into Windows. It only says it is possible but that "it is not included here because it completely deletes hiberfil.sys and will cause you to lose all unsaved information in the hibernated Windows programs". – terdon Nov 20 '13 at 13:12
  • @terdon 2 ways to reply: the info is incomplete. Yes but... there is pretty much what you need to set up your own command, the key point is that the post alerts you to a possibility many people even ignore. Second way: but I am running a risk. True, but if you can't/do-not-want-to use Windows, the article makes it pretty clear there are no alternatives. – MariusMatutiae Nov 20 '13 at 13:21
1

According to the ntfs-3g man page, there is an option that allows you to do this:

   remove_hiberfile
          Unlike  in  case  of  read-only  mount,  the read-write mount is
          denied if the NTFS volume is hibernated.  One  needs  either  to
          resume  Windows  and  shutdown  it  properly, or use this option
          which will remove the Windows  hibernation  file.  Please  note,
          this  means  that  the  saved Windows session will be completely
          lost. Use this option under your own responsibility.

So, I stress that this will destroy any unsaved data that is in the hibernated Windows session. If that is not an issue for you, you should be able to access the drive by running (why in the world do you have a space in your mount point?):

sudo ntfs-3g -o remove_hiberfile /dev/sdb2 /media/cobolt/Legalise\ it/

That should mount the drive correctly and since it will delete the hibernated session file, it should mount normally from now on.

-2

sudo ntfsfix /dev/sdXY worked for me where sdXY is the drive device identifier.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.