21

When you download something in chrome, it automatically runs an antivirus check on the file. If it detects it as dangerous, it puts a warning and a discard button in the downloads bar at the bottom. If you click the arrow you can chose Keep.

I want to disable this on my computer, as my computer's antivirus will pick it up anyway. How do I do this?

  • 1
    @Ramhound Yes but those solutions also disables the malware check when browsing. I only want to disable the download file scan. – Jon Nov 21 '13 at 0:00
  • I wrote a patch to disable the check as it was simply based on the file extension in which is in my answer on question superuser.com/a/594800/44887 which this question might be considered as a duplicate of. – Dan D. Nov 22 '13 at 15:07
  • If it detects it as dangerous, it puts a warning and a discard button in the downloads bar at the bottom. And it seems to be finicky and arbitrary too. It’s not clear exactly how it determines what is “unsafe”. I have seen it let one file from a web page through while nagging about another, very similar one from the same page. The only explanation is that Chrome actually contains a built-in full anti-virus scanner. If so, then it has most definitely become bloatware (which would also explain its massive growth since the first version). – Synetech Nov 26 '13 at 5:13
  • There's now an option to save the file anyways from the chrome downloads window, FYI – Kevin Sep 26 '15 at 5:29
8

Try to start chrome with this switch:

--safebrowsing-disable-download-protection

although I don't know if it works. Grabbed it from here: http://peter.sh/experiments/chromium-command-line-switches/#safebrowsing-disable-download-protection

| improve this answer | |
  • Does that disable the malware check while browsing? – Jon Nov 22 '13 at 15:13
  • No, it's download only. – Dim Nov 22 '13 at 16:04
  • 10
    Surprise, surprise; they are planning on removing it to force the download checking whether you like it or not. Even an anti-virus program can be disabled. ¬_¬ – Synetech Nov 26 '13 at 5:09
7

This answer was submitted more than 7 years ago and is not accurate with more recent versions of Chrome. This answer will not be updated since it was submitted to answer the author’s question which was asked in 2013.

Disable phishing and malware detection

  1. Click the Chrome menu Chrome menu on the browser toolbar.
  2. Select Settings.
  3. Click Show advanced settings and find the "Privacy" section.
  4. Deselect the "Enable phishing and malware protection" checkbox

Source

| improve this answer | |
  • 1
    This option has been renamed as "Safe Browsing" under the "Sync and Google Services" section in Settings. Searching for "safe" in the settings search will find it, but not "malware" and "phishing", as those terms have been removed from the setting's description. – SW_user2953243 Sep 2 '19 at 21:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.