1

After upgrading to a Samsung 840 SSD drive, I have problems with image backups failing verification when the SSD is plugged into any of the ICH9 SATA ports in AHCI mode.

The motherboard also has two "Gigabyte" SATA ports labeled GSATA in the motherboard manual.

After setting the GSATA ports to AHCI mode, I tried moving the Samsung SSD over to one of the GSATA ports.

When Windows 7 tried to boot, it blue-screened.

Is a special driver necessary? Gigabyte has a RAID driver for the GSATA port, but I'm not using RAID. I tried loading the Gigabyte driver manually from Device Manager, but Windows says the "existing driver is up to date".

I have already made the registry tweaks to enable AHCI (when I installed the SSD I changed the SATA ports from IDE to AHCI)

0

Were the GSATA ports in IDE Mode or AHCI mode before ?

You may need to uninstall the drivers and then reinstall them to get Windows to work nicely with the SATA ports after you've changed them to AHCI mode.

In the past, I've had issues with Windows not playing well with one of my SATA ports when I changed the mode from IDE to AHCI.
I had to reinstall the drivers for that one SATA port before it would work well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.