I am trying to load the openssl module, I uncommented it in the php.ini:


But when running my script I get an error:

Failed to connect: 0 Unable to find the socket transport "ssl" - did you forget to enable it when you configured PHP?

From the PHP documentation:

After activating an extension, save php.ini, restart the web server and check phpinfo() again. The new extension should now have its own section.

I am using a windows server machine, This is production, I really don't want to reboot the server, is there an alternative?

  • what type of server do you have ? "Appserver" "wampserver" ??? you have to find httpd.exe process and kill it then restart it
    – Hichem
    Nov 21, 2013 at 20:21
  • @k3rnel31 its IIS, sorry I forgot to mention
    – meda
    Nov 21, 2013 at 20:37

5 Answers 5


To restart PHP on IIS, you actually need to restart IIS:

Click Start, click Run, type IISReset, and then click OK.

WinR iisreset

Or, more verbose: iisreset inside a powershell opened as administrator - or even inside a Cygwin shell.

enter image description here


For those that stumbled upon this answer and you're running Windows 10 or another version with PHP but you're NOT running any of the usual web server apps (WAMP, ServerDesktop, IIS, etc), open your task manager and you will probably see "CGI/Fast CGI" which is the PHP. Right-click and end task. The app will not go away but instead, restart with your updated configuration.


I've found that, instead of restart IIS entirely, it's just enough to restart the Application Pool associated with the specific site.

By IIS Manager, first click the Site name on the left panel, then "Basic Settings" on the right panel, so you can see what's the associated application pool. Finally go to "Application Pools" section, click the proper pool and then click "restart" on the right panel.


To restart PHP on IIS, you actually need to restart IIS:

Go to Start -> click Run -> type iisreset, and then click OK.

If iisreset command is not recognized, then

  1. Click win -> search "Turn windows features on or off"
  2. Tick the checkbox "Internet Information Service"
  3. click ok and after completion try the above process again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .