I have a bizarrely borked ASUS board (M5A97 LE R2.0) that is stuck in a half way state between two BIOS versions. I cannot enter the BIOS settings page (the system locks up after drawing half of it). It will not POST if there are any USB devices or GPT partitioned disks attached. Removing those –and with some monkey business to get a keyboard– I am able to boot UBCD, so I do have access to a few tools.

I also setup a DOS boot disk using FreeDOS with the ASUSTeK BIOS Updater for DOS V1.30 and am able to find the CAP file from ASUS that should be the latest BIOS. Unfortunately when attempting to flash it it checks the file, then throws this error:

"Failed to load the secure BIOS."

I have been unable to figure out how to make this utility go or find a file that it likes. I've tried the latest 4 versions for this board posted on ASUS's site.

I also tried flashing using FTK, but it was unable to run in the FreeDOS environment I had setup. I also tried flashing from Linux using flashrom, but that failed for another undetermined reason.

What other options do I have for re-flashing this BIOS? What might the ASUSTeK utility not like about my ROM files?


So having tried several other BIOS flashing tools on this system to no avail, I decided the BIOS might be so borked that it wasn't going to be able to flash itself and that it needed outside help.

Unfortunately I imported this board and getting warranty service on it would be a lot of hassle. I was unable to locate a new BIOS chip, so I decided to try to remove it externally.

Of course I was also unable to find an EEPROM programmer. I'm sure they exist, I just couldn't find the right people to ask, so I opted to build one. This turned out to be easier than I expected.

I had a couple Raspberry Pi boards lying around and read that it has an SPI interface necessary for this sort of thing. The author of flashrom seemed to think it should be possible, and more recently there is a wiki page on the flashrom site with the necessary pinouts. That lead me to this tutorial, which I more or less followed.

Another trip to the electronics parts bazaar for a breadboard, some resistors, a capacitor and some wire, and I was ready:

rPi flasher

Crazily enough, it worked!*

I cut the CAP header off of the latest bios image file (dd bs=2048 skip=1 if=BIOS.CAP of=BIOS.BIN) and used flashrom to write it (flashrom -p linux_spi:/dev/spidev0.0 -w BIOS.BIN). After sticking the chip back in my motherboard, it boots just fine. I can open the BIOS and have successfully setup my OS.

* I know it's not pretty. I'm not a hardware guy and didn't have access to proper tools or supplies.


I don't have any immediate software suggestions; however, ASUS does offer pre-flashed replacement firmware chips for sale on their Web site. Try going to http://shop.asus.com and follow the links for your country.

Alternatively, you could buy an EEPROM programmer and flash the firmware yourself using another computer, at least in theory. (I don't know if there are any significant "gotchas" in such an approach, such as converting the file from whatever format ASUS provides to whatever the EEPROM programmer's software needs.) A new EEPROM programmer is likely to cost more than a pre-flashed chip from ASUS, though. OTOH, if you know somebody who has one that you can borrow, that will be cheaper, even if you decide to buy a blank chip to avoid risking your current semi-working one.

  • Thanks for the suggestions. Unfortunately "my country" isn't one that Asus will ship parts to and locating a replacement chip might be kind of hard. I will however be going down the EEPROM flasher path if I can't come up with something else pretty quick. – Caleb Nov 22 '13 at 0:15

ASUS actually has a troubleshooting guide on how to recover from a bad BIOS flash. Your BIOS has a "boot block", which is a part of the flash memory that is normally untouched by flashing a new version. ASUS calls this feature CrashFree.

Though the first thing they suggest—and, indeed, it may be the problem you're seeing—is to use the clear CMOS jumper and/or switch to clear out all the settings. Other than that, you want to get the Boot Block (CrashFree) to run and flash the BIOS from a CD (there should be a "Motherboard Support CD" included with the board—use it). Its supposed to run automatically if the BIOS checksum is bad, and unfortunately it seems the only way to force it to run is to short pins on the flash chip.

This is a fairly new board, you're probably still under warranty, so if the troubleshooting guide doesn't work, you probably want to RMA the board.

  • Where did you find information on shorting pins to force the CrashFree utility to kick in? – Caleb Nov 22 '13 at 10:43
  • @Caleb I asked Google about award bios force bootblock recovery. One such result is here. There is a guide here. Note these are quite old, it may not work with newer flash chips. Not sure. If you can find the flash chip and read the model # off it, electronics.SE can probably let you know if it's doable. – derobert Nov 22 '13 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.