I've been having problems since I upgraded to Windows 8.1. My battery has been having issues as its getting old, and it always says its at 0%, while in fact I can still use it for about 2 hours.

This wasn't a problem in Windows 8, but since I upgraded, my laptop automatically shuts down when I remove the power cord as it thinks the battery is empty.

Can anyone tell me how I can disable this? I have been searching for quite some time, but on every forum this has been posted, the only responses those people get is something like, "Why would you want to do this?".

This has been going on for the past weeks and its very frustrating, so any help is appreciated.

3 Answers 3


Time for necromany, as there IS a way to set the critical battery action to "Do nothing".

It's not entirely safe, the critical battery status is there to prevent data loss on shutdown, but if you don't do anything data-critical, windows handles this fairly well.

The trick is to use the command line powercfg utility.

  1. Open an administrator console (cmd.exe with administrator rights).

  2. Type: powercfg -setdcvalueindex SCHEME_CURRENT SUB_BATTERY BATACTIONCRIT 0

    (This modifies the power scheme currently active, so if you need to modify an other, switch schemes.)

  3. Open the "Power Options" like described in @Synetech's answer and jump around happily seeing that Critical battery action is indeed "Do nothing" when "On battery".

  • Great!! Thanks mate, works perfectly. For anyone reading this, please be carefull. If you configure the critical level to do nothing and running a non SSD drive, it could hurt you.
    – Rubaijat
    Commented Aug 16, 2014 at 20:03

do what @SoonDead said but for sleep use

for hibernate use

for shutdown use

note that values for this setting are as follows:
0 is do nothing
1 is sleep
2 is hibernate
3 is shutdown


Have you tried configuring your power policy?

  1. Open the Power Options page:
    • Control Panel → Hardware and Sound → Power Options (figure 1) or
    • Search for power (figure 2) or
    • From the notification area (figure 3)
  2. To edit the current power policy, click Change plan settings (you can also edit other policies or create a new one) (figure 4)
  3. Click Change advanced power settings (figure 5)
  4. Expand the Battery branch
  5. Edit the actions for the different battery states (figure 6)
  6. Click [OK]


I have also looked into the "Critical battery action" tab, but there I can't configure it to do nothing, while I can do that for the "Low battery action"

I guess the rationale is that once the battery is so low that there’s nothing left, you have to do something. You can try adjusting the levels in that dialog (figure 6) to define what “low” and “critical” mean (e.g., change low to mean 50% or 1%, etc.) If your battery level gets reported as being low, but non-zero (e.g., sometimes 5%, sometimes 1%), then you could set critical to be 0%.

However, if your battery really is always reporting 0% (and not even 1%), then the fact is that the gauge in the battery is simply defective and I’m afraid the only resort is to either stay plugged in or get a new battery. The conceivable only way to prevent Windows from sleeping when the battery reaches 0% is to hack the system because there is no method (either built-in or via a third-party program) to prevent it because a 0% battery is like pulling the cord out of a desktop system.

Figure 1: Control Panel Power Options applet

Figure 2: Power Options from search

Figure 3: Power Options from notification area

Figure 4: Power Options applet

Figure 5: Power plan settings editor

enter image description here

Figure 6: Battery state actions

enter image description here

  • 1
    I have tried this, but it doesn't fix the problem. I have also looked into the "Critical battery action" tab, but there I can't configure it to do nothing, while I can do that for the "Low battery action". Commented Nov 22, 2013 at 8:13
  • Yes, the OP is asking how to set the Critical battery action (not the Low battery Action) to "Do Nothing", which cannot be done using this answer :) Commented Nov 4, 2017 at 7:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .