I have the Razer Deathadder mouse (left handed edition) and some of the buttons don't work on Linux. For example the back and forwards buttons on the side, pressed by the thumb don't work and pressing down on the scroll wheel doesn't do anything. As far as I can tell Razer hasn't come out with software for Linux.

Update: as per Journeyman Geek's recommendation I'm trying to install a third party configuration tool but I'm stuck at the install part

screen shot of trying to install

Update 2: as per Dennis' comment I have installed the configuration utility and have copied razer.conf to /etc/razer.conf what is the next step?

I'm using the latest version of Mint Linux. What must I do to get this functionality?

I found a file that gives me a window that looks like it's for setting configuration but none of the options have anything in the list when I click on them

screen shot of razer device window

Output of ps ax | grep razer

 1935 ?        S      0:00 /usr/local/sbin/razerd -f -B -P /run/razerd/razerd.pid
 4210 pts/0    S+     0:00 grep --colour=auto razer

I forgot to mention that Linux is running in VMware Player. Here is the output of xinput

screenshot of output of xinput

  • You will need to map the buttons to make them do something. What distro are you running ?
    – Lawrence
    Commented Nov 22, 2013 at 7:08
  • 1
    @Lawrence well go on. Saying map the buttons certainly isn't enough but it may be a good start. I'm using Mint.
    – Celeritas
    Commented Nov 22, 2013 at 8:50
  • Well I need to know where to start to go on lol. Have you had a look at this link ? - help.ubuntu.com/community/ManyButtonsMouseHowto
    – Lawrence
    Commented Nov 22, 2013 at 14:01
  • 1. Executing sudo -i changes to root's home directory. Just execute sudo make install instead of sudo -i followed by make install. 2. Do the mouse buttons get recognized at least? Execute xev from a terminal, your cursor over the window that opens up and, while maintaining the cursor perfectly still, press the scroll wheel and the thumb buttons. If they do get recognized, you should see Button press and Button release events.
    – Dennis
    Commented Nov 25, 2013 at 22:07
  • 1) worked 2) the left button, right button, scroll wheel, clicking the scroll wheel are detected. The two side buttons where the thumb show no change.
    – Celeritas
    Commented Nov 25, 2013 at 22:26

1 Answer 1


In many cases, razer hardware dosen't really do things in a standard way, or needs a little prodding for things to work right. I've not gotten a chance to test it out myself, but there's a FOSS, unofficial driver/configuration tool for razer mice, and regular deathadders seem supported. I suspect the left handed version should work.

If this dosen't work, you can check if these keys actually do something with evtest, then map them with an appropriate tool - It may not be trivial it may need the mouse to get a specific message from the system, as with their keyboards, and this may need some hacking around.

That said, all this is meant for physical systems. You might be able to configure a keyboard shortcut in windows then bind that to something on linux or to passthrough the mouse to the vm, possibly. I tried the former and it worked. The latter resulted in a frozen, unusable mouse. Quite frankly, the question as originally written was entirely plausible. The current scenario, post edit is just not something thats worth the effort.

  • Thanks, I'm brand new at Linux so I need some help. I'm following the instructions in the readme file but there is no make file so I'm stuck. e.g. under the heading "installing" why does it say to make install?
    – Celeritas
    Commented Nov 24, 2013 at 22:18
  • cmake . is supposed to make the makefiles for you- you did install the deps, then run that before make install right? I don't have a mint system, but the commands given do make sense if I were compiling this for ubuntu.
    – Journeyman Geek
    Commented Nov 25, 2013 at 1:12
  • I installed the dependencies and ran cmake . and make but when I got to the part where I run sudo -I and make install it didn't work and said "make: *** No rule to make target install'. Stop.". I ran pwd` and it said /root and wouldn't let me cd to the directory where I had the files from razercfg. What should I do?
    – Celeritas
    Commented Nov 25, 2013 at 4:43
  • you don't need to run make after cmake. cmake does what make does... being at root is kind of odd though. I'll see if I can get a VM up to try the compilation part of it and see what's happening.
    – Journeyman Geek
    Commented Nov 25, 2013 at 5:11
  • I've got it installed but I'm not sure how to edit the razer.conf file
    – Celeritas
    Commented Nov 27, 2013 at 0:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .