2

Guest operating system is Windows 7 and I have VMware player 6.0.1 installed. On it latest version of Mint Linux is run. The problem is Linux never gets sound. How do I fix this? The message "the default sound device cannot be opened" is given in the Player.

I tried following these instructions but the sound card is already there and the "connected" option is grayed out screen shot of VMware Player settings

I also tried these instructions but can't find any vmx file however I can find a vmxf file.

  • Try uninstalling and reinstalling VMware Player sometimes it could help. – vembutech Jun 23 '15 at 17:48
  • Try updating VMware tools rather – pun Jul 24 '15 at 22:51
1

If lspci|grep snd_ens1371 gives some output the sound kernel modules are loaded & sound is probably muted in alsamixer. Muted channels show up as 'MM' & can be unmuted by selecting them & pressing M.

If alsamixer does not detect a sound card run:

alsactl init

If you are using pulseaudio check /etc/asound.confcontains a minimum of:

pcm.pulse { type pulse }
ctl.pulse { type pulse }
pcm.!default { type pulse }
ctl.!default { type pulse }

I also changed the sound device settings in VMWARE to my detected speakers (from default host device).

Reboot & sound will work.

This fixed xfce4-volume-control / gstreamer complaining no sound card can be found & warning of a possible permissions problem. Trying to run just ALSA under Debian Wheezy 64 bit in VMWARE still gave this gstreamer error. VMWARE seems to run a little better with pulseaudio also being installed (sound in Virtualbox ran just fine with only ALSA).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.