There doesn't even seem to be the option in Safari. And while the Java plugin is installed on Firefox, it doesn't work there either, which makes me think it might be a system-wide issue. I do have Eclipse and a few other Java applications on my computer, and they all work fine.

I looked all over the place, and I found out that Java should be an option in the preferences window in Safari, but it's not there:

No Java here

  • I was just working on someone else's iMac yesterday which was recently upgraded to Mavericks, and if I recall correctly, the fix was simply to enter the command java -version in Terminal, which lead to a diskimage of most recent version of the Java Runtime Environment being downloaded (after prompting me to do it). Afterwards I just mounted and installed it. – martineau Nov 23 '13 at 13:20
  • @martineau Thanks, but Java is already installed on my actual system. I already have Java applications running on my computer, but the Java plugin isn't loading on any web browser (I tried Safari, Firefox, and Chrome). – Hassan Nov 23 '13 at 16:38

In additition to Martineau's response I had to set the Security Level slider to Medium in order to run applets that do not have a certificate from a trusted authority.


You should be able to enable Java in your browsers by going to the Security tab of the Java control panel (System Preferences | Java).

Here's some screenshots of what I'm talking about:

System Preferences showing Java icon

When you click the Java icon the following appears, then click on the Security tab and enable the first option as shown:

Screenshot showing Java security tab options

  • 2
    Thanks for the answer, but I don't have a Java control panel in my system preferences. I also don't get any results when I search for Java in the search box. Java was installed by OS X when I tried to run a Java application. – Hassan Nov 24 '13 at 19:09
  • The one on the system I was using was the same one that I executed the java -version command upon to obtain and install the latest version following the OS X Maverick upgrade I performed. – martineau Nov 24 '13 at 22:00
  • 1
    Thanks, for the extra detail. Unfortunately, this is not what I see in my preferences window. There's no Java option at all. – Hassan Nov 25 '13 at 5:31
  • Why don't you try executing the java -version command to insure you have the latest version? – martineau Nov 25 '13 at 7:45
  • 1
    Okay. I get java version "1.6.0_65". Not the latest version on Java's website, but I'm not sure if it's the latest provided by Apple. – Hassan Nov 25 '13 at 13:00

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.