0

My LAN originally took about 3-5 minutes to achieve Internet connectivity. This was way too long for me, so I found this fix which basically said:

In advanced settings of network adapter, for "Speed and Duplex" I set "10 Mbps Full Duplex"

I set it to "100Mbps Full Duplex" (previously, it was set to "Auto") and now my adapter achieves Internet connectivity almost instantly.

My question is, why did this fix my problem? I'm just curious as to the internal working in this situation.

0

Your network cable is badly broken, most likely having the wires assigned to pairs incorrectly.

Just having both ends using the same assignment is not enough. Signal pairs must be assigned to wire pairs because wire pairs are twisted differently to reduce crosstalk. Mismatching will turn this against itself, causing each half of a signal pair to be twisted differently, and worsen crosstalk.

Do not ever force full duplex, it will cause huge problems. Fix the broken cable. Pick either 568A or 568B and ensure both sides are wired according to it.

| improve this answer | |
  • Okay this makes sense! Thanks! But, I have another laptop which does not have this problem (i.e. I don't have to force full duplex to connect fast). What does this mean now? – Anish Ramaswamy Nov 23 '13 at 20:42
  • @AnishRam It is perfectly consistent with the cable being marginal. Marginal hardware behaves unreliably. – David Schwartz Nov 23 '13 at 22:20
0

Sorry, you probably won't like this answer - a dodgy adapter or driver (probably both, as I'd imagine they go hand-in-hand). Any half-reasonable adapter should automatically detect the correct link settings within a very short period (<2 seconds ?).

It may also be that while Autonegotiation was occurring the link was considered up by your PC but down by the switch. Your computer then sent out a DHCP request shortly before the link was up, and did not get a response. It then waited a few minutes to retry. [ This should not happen, of-course ]

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.