0

I'm not sure if this is this right place; If it isn't; please redirect me to the correct forum. I dual booted my computer which originally had Windows 7 installed on it, with Backtrack 5 R3. I went through the install process perfectly and BT was working very well.

I then restarted my system and booted up into Windows. I went into disk management, because I was curious about what partition BT was installed on, and by mistake I deleted the partition that it was installed on.

I thought there was nothing on this partition and was really stupid not to check how much space had been used on the drive. Anyways, I restarted my computer and came up to the screen that says:

"error: unknown file system Grub rescue>!!!!!! This is EASY to fix, I had it once before with Linux Mint. I just repaired the boot loader with my Windows 7 Recovery Disk. However, this time it is not as simple. I cant boot into ANY CDs/DVDs, including my Windows 7 disk and backtrack, even though my first boot device is set to Internal CD ROM.

The problem is that when I boot up my computer, I cannot access my BIOS. No onscreen keys r shown (the usual F2 on my LG laptop). I have tried all key combinations incase it had switched my BIOS key, which is very unlikely, but it was worth a shot. It just takes me straight to the GRUB rescue prompt where I can virtually do nothing. I,ve tried LS at the rescue and tried to boot up into one of the hard disks, help commands and any other obvious commands that I thought might work, but nothing!

I cant remember off-hand all the model numbers, but my laptop is an LG , as I mentioned above and have a Toshiba HDD.

Anything else you need to know ?

How can I fix this?

migrated from stackoverflow.com Nov 23 '13 at 9:21

This question came from our site for professional and enthusiast programmers.

0

You can boot into Windows from your Grub prompt with the following sequence of commands:

 root (hd0,0)
 makeactive
 chainloader --force +1
 boot

The key command here is the first one, which specifies Grub will have to search for a bootable OS on the first disk (hd0), first partition (the second 0 on the root command line). Should your Windows system be on a different disk or partition, you will have to fix this command accordingly.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.