2

Complete Linux novice here, I've been trying to set up one of my disks in my server as a Time Machine backup.

Below is a follow up from this post: http://www.reddit.com/r/applehelp/comments/1r7rzy/trouble_setting_up_time_machine_share_on_ubuntu/

I've been Google-fuing away with some success, I deleted and reinstalled NetaTalk, I could see the server but when I tried to set it up I got this error:

Time Machine can't access the backup disk "TimeMachine". 

The operation couldn't be completed. (OSStatus error 2.)

A quick change of permissions fixed that.

I can now access my drive on my server and point Time Machine to it. Only one problem, it's only showing less than ~30GB of space on the drive.

For a quick test I tried creating a folder on the Time Machine drive on my Mac but it never showed up on the Ubuntu side.

Screenshots - http://imgur.com/a/vrzV2

Now this could be two things;

  1. It could be pointing to my OS SSD in the sever
  2. The size of the Time Machine drive is limited some how.

This is what is in the /etc/netatalk/AppleVolumes.default file at the moment

# By default all users have access to their home directory
#~/                "Home Directory"   options:usedots,upriv    ea:ad
/mnt/TimeMachine/tm_backup "TimeMachine" options:usedots,upriv,tm ea:ad allow:myusername

Tried redefining where the backup is

mkdir /mnt/TimeMachine/tm_backup
sudo chown username:username /mnt/TimeMachine/tm_backup
chmod 755 /mnt/TimeMachine/tm_backup

But it's still saying that there is ~30GB of space on the drive

Second guide I used: ubuntuforums.org/showthread.php?t=1811541

1

I hope you found the solution with time but just in case. I had the same error but with a Debian 7 And I correct it just by removing a Comment I had on my shared drive.

my rights are

  • chmod -R 775
  • chown -R root:users
| improve this answer | |
  • Which comment did you remove? This answer isn't much help without that. – Chenmunka Feb 15 '16 at 10:42
  • The comment you give to your share into the afp.conf to describe your share. netatalk.sourceforge.net/3.1/htmldocs/afp.conf.5.html Such as example my share was "tm_jodumont" with the comment/description of "Time Machine for JOduMonT" and my Time Machine wasn't able to write in until I remove my comment/description on my share. – JOduMonT Feb 18 '16 at 13:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.