13

I'm running Ubuntu 13.04 and the max resolution it's letting me choose for the monitor I currently have plugged in - a 1280x1024 monitor - is 1024x768. The description for the Monitor is "Unknown". See attached:

Unknown monitor

The monitor is an IBM ThinkVision L170P.

11
+50

From https://askubuntu.com/questions/139947/why-cant-ubuntu-12-04-detect-my-screen-resolution

Open your terminal and run this:

xrandr --newmode $(cvt 1280 1024 60 | grep Mode | sed -e 's/.*"/1280x1024/')
| improve this answer | |
  • 6
    I had to do xrandr --addmode VGA1 1280x1024 as well but otherwise your solution worked! – neubert Dec 6 '13 at 7:04
  • 2
    xrandr --newmode $(cvt 1920 1080 60 | grep Mode | sed -e 's/.*"/1920x1080/') – atilkan Aug 21 '15 at 4:38
  • It worked, but why I have to run it every time the system starts? – Fahad Khan Oct 2 '15 at 5:18
10

First type xrandr -q to see your valid screen outputs eg. VGA1/DVI-1 etc...
Then xrandr --addmode DVI-1 1600x1200
Then new option will appear in your Displays configuration
Tested on ubuntu 14.04 and 2 screens ;)
note this change is not persistent after restart. To make it persistent I made shell script which do above mentioned command xrandr --addmode... and then I add line to file /etc/lightdm as follows

[SeatDefaults]
display-setup-script=pathToYourScript

this way new resolution is added before desktop try to set it...

| improve this answer | |
  • Just to add, make sure that "pathToYourScript" is executable. You can place it in /opt/ also. – M. Ahmad Zafar Mar 5 '16 at 7:58
3

For 1920x1080 res 60 Hz use following:

xrandr --newmode $(cvt 1920 1080 60 | grep Mode | sed -e 's/.*"/1920x1080/')
xrandr --addmode VGA-1 1920x1080

One may encounter different output names: VGA1, VGA-1, etc.

More info HERE.

| improve this answer | |
  • This appears to duplicate the accepted answer plus the OP's comment, only this version has the wrong resolution. – fixer1234 Nov 9 '18 at 9:03
  • The issue is that one comment mentiones VGA1 in addmode, in my case it's VGA-1 . And I have to get new resolution to work.It's just putting together nuances that may help others. – alex Nov 9 '18 at 15:16
2

Try installing mesa-utils using sudo apt-get install mesa-utils.

Once you have this installed reboot your machine. After rebooting the machine open a terminal and type glxinfo | grep render and glxgears

That should fix it.

| improve this answer | |
  • I'm running Ubuntu LiveCD on this particular machine so that wouldn't work unfortunately :( – neubert Dec 6 '13 at 7:05
  • 1
    i don't think this is relevant. not working also. – atilkan Aug 21 '15 at 4:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.