0

I recently reinstalled Windows 7, and I noticed that I do not automatically receive an IP address when I start up the computer. When I reset, it makes it get an IP address, and I can surf like normal, but when I bring it back down and up again, it loses it.

Now, I at first thought it was my school's network causing problems, since it does have issues, however, when I took my desktop home for break, I ran into the same issue, so the problem is most likely on my machine.

If I try to use ipconfig/renew, I get this error:

The operation failed as no adapter is in the state permissible for this operation.

In my network settings, it is set to automatically get an IP address

I'm on an Ethernet connection.

0

Seems the network-card driver is acting funny and doesn't initialize properly on a cold-boot of the computer.

There could be many reasons for that but usually it's just Windows being confused.
I have outlined the basic troubleshooting procedure for dealing with network-card issues in Windows below.

First go into the BIOS of the computer and do a reset to factory defaults. Then select the "Load optimized defaults" option (if that is available, it depends on the kind of bios you have).
Go into Windows and see if you problem is solved.
If not: open the device manager (Right-click on "My Computer" and select "Manage", then look for the device manager section in the tree-view on the left.)
Find the network adapter among the various pieces of hardware.
Delete the network adapter !
Now reboot the computer.
On the next boot Windows should re-discover the network card, re-install the drivers and refresh all the settings related to the network.

If all this still doesn't help check to see if the manufacturer of the network card has a newer driver.

Still no luck ? In that case the network-card could be faulty: Get yourself a Linux live-CD (or USB stick) and boot the computer from that. If that works OK with the network-card you can be certain that the hardware is OK and the problem is something with your Windows installation, that didn't get solved with the steps above.

If it is Windows and the above didn't help then it will be very hard to fix it. You will have to have someone look at it who can really troubleshoot this hands-on. Or do a full re-install of Windows.

  • This happens on the Slackware side of my computer as well. So I think it might be hardware related... – user1768884 Nov 24 '13 at 22:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.