In Windows 7, how can I set the default PowerShell window size? By default it comes up too tall for the netbook screen I am working with.

I have tried the usual way of changing the size—by clicking in the upper-left corner and choosing “Properties”—but it tells me: Unable to modify the shortcut: . Check to make sure it has not been deleted or renamed. (yes, there is a dot in the middle of the error message)

I also tried right-clicking on the PowerShell shortcut in the Start menu and changing properties there, however, the changes don’t seem to stick.


Use a function like this in your profile (notepad $profile)

Function Set-WindowSize {

    $size=New-Object System.Management.Automation.Host.Size($x,$y)

Then call the function:

Set-WindowSize 100 50
  • Thanks. This works, as long as I Set-ExecutionPolicy unrestricted, which is a little worrisome, but I guess I would have to do it eventually to get anything done under PowerShell. – Nate Nov 9 '09 at 17:46
  • setting "WindowSize": "Window cannot be wider than the screen buffer. – villasv May 14 '16 at 4:59
  • As for where the $profile file is... blogs.technet.microsoft.com/heyscriptingguy/2012/05/21/… – Glen Little Jan 24 '18 at 23:58

Go Start -> All Programs -> Accessories -> Windows PowerShell. RClick on the one you're using. Go to the Layout tab, and change the settings you want.

  • 2
    This works just fine for any shortcut for PS, such as if you've pinned it to your taskbar. – James Skemp Jul 23 '15 at 22:42

Another approach is to run Powershell as an administrator. See How do I modify the Powershell console settings in Windows 7?


You could try Properties, Layout tab, Window Size.

I was also able to grap the top RIGHT most window and re-size in the traditional Windows way.

You could try launching the GUI alternative: PowerShell ISE.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.