4

I've recently found out that I can no longer copy text out of MacVim and paste into other Mac apps. I used to be able to do this on Mountain Lion.

I have the usual configurations set, namely:

set clipboard=unnamed

I have tried with a virgin, no configuration version of Vim with +clipboard set when building. It was built using Homebrew.

I have tried the Cmd-C combo, the "+y key combo, the yy combo, and others. Nothing seems to work.

The clipboard otherwise works fine for all other apps on the computer.

Am I experiencing an incompatibility that is new?

  • It works perfectly, here. Do you use the latest snapshot? How do you install it? – romainl Nov 26 '13 at 4:47
  • Works well for me too. Ver. 7.4 compiled by homebrew on 21/10/13. – Jin Nov 28 '13 at 19:13
  • 1
    I am experiencing the same issue. I'll note that I also run vim inside of tmux. – G Gordon Worley III Dec 10 '13 at 22:33
  • I'm having the same problem, I can't even copy & paste in MacVim with set clipboard=unnamed, the * register is not working and yanking into this register silently fails. stackoverflow.com/questions/20759289/… – koo Dec 24 '13 at 13:58
  • 1
    are you launching Vim from inside of tmux? If so this is a known issue. Fix is here: github.com/ChrisJohnsen/tmux-MacOSX-pasteboard/blob/master/… – Ben McCormick Jan 19 '14 at 17:37
0

I had the same issue having MacVim installed and running vim in Terminal.app. It turns out that by default MacVim does not override system vim which hasn't clipboard support (vim --version prints -clipboard).

Reinstalling MacVim:

brew reinstall macvim --with-override-system-vim

and relaunching Terminal.app session solves the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.