0

I am trying to sync two folders along their extended attributes, however some files are always synced every single time without any apparent reason.

Debugging rsync I found out that the remote file flags value is different from the one I have locally:

[sender] i=34166 /Volumes/MyDisk Documents/local/ mode=040755 len=204 uid=501 gid=20 flags=0
[receiver] i=34166 2 Documents/local/ mode=040755 len=204 gid=20 flags=88

I tried deleting the remote folder and sync the whole thing again, but I always get problems where some files/folders are constantly recognized as modified.

What is included in the flags field? I have tried comparing the attributes and ACL of both folders with "ls -lO@ae" and they look the same.

0

In 90% of the cases I use rsync with the following arguments:

rsync -vaH --delete from_dir/ to_dir/

And the "rm" command as "rm -rvf". But I see that you are using OSX, which has a primitive version of rm, which can't always recursive delete without questions and warnings. I suggest you should google for "gnu fileutils for osx" or same, and install what you found. That rm can.

With rsync doesn't exist this problem, because I has not a primitive version, which the wonderful apple could integrate. :-)

0

Still not sure what was the difference with "flags", but solved this problem by upgrading rsync

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.