8

I shouldn't have installed Adobe Reader on my Mac. But now that I have, how do I set Safari to (go back to) show PDFs using Preview (as the inline PDF display plug-in) instead of Reader? Do I need to uninstall Reader?

Update: I went ahead and uninstalled Adobe Reader. (I grew tired of constant reminders to update something I wasn't using.)

4

The "Right Way" to accomplish this is actually within the Adobe Reader app. Just go into preferences, click Internet, and uncheck Display PDF in Browser. Simple and non-destructive, since Adobe will almost certainly attempt to "repair" itself when it notices the plugin file missing at the next security update.

  • This sounds like the right answer, but I can't verify since I uninstalled Adobe Reader since posting this question. – Daryl Spitzer Jul 26 '10 at 3:57
  • 2
    This no longer works with a recent Adobe and is a known issue: superuser.com/a/254624/65618 – ShiDoiSi Nov 6 '12 at 9:02
8

It is neither necessary nor sufficient to uninstall the Adobe Reader. I went also through this process and finally succeeded by (re)moving

/Library/Internet Plug-Ins/AdobePDFViewer.plugin. 

More information can be found here.

  • I, of course, had to restart Safari after deleting this file. – Daryl Spitzer Nov 9 '09 at 20:20
-2

You should be able to "Get Info" on a PDF (cmd+I or right click the file) and then set the default viewer for that file type.

  • But this launches Preview as a separate process whereas it is possible to use Preview as an inline reader directly in Safari. – Uwe Honekamp Nov 9 '09 at 19:18
  • Right. I'll clarify my question. – Daryl Spitzer Nov 9 '09 at 20:15
  • Daryl Spitzer is asking about the Acrobat plugin, not PDFs opened from the finder. – Josh Nov 9 '09 at 20:43
  • The default setting on the file itself is what Safari uses. Setting the file within the Finder will also set it for Safari (unless Acrobat is over-riding that - which would be new to me). If you want to keep the plugin installed, I believe the following terminal command sets it as the inline viewer: defaults write com.apple.Safari WebKitOmitPDFSupport -bool NO – Insomnic Nov 9 '09 at 21:21
  • Insomnic, can you verify that Safari & Adobe Reader honor the Finder setting, and verify that the default setting works as you describe? (I've already deleted the plug-in and would rather not re-install it.) – Daryl Spitzer Nov 9 '09 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.