I am trying to use SmartFTP Client to transfer files from one remote site to another (FXP with FTP).

The transfer starts OK but after the first few files everything stops. The connection from my PC to my router is totally dead and I need to restart the router to reconnect to anything with that specific PC.

The router is still connected to the internet as no other devices in the house have a problem.

I have a Belkin router with the latest firmware:

Hardware: F5D8233-4-v1(01A) Firmware
Version: 1.01.15 (Dec 27 2007 18:39:03)

Update: I'm using FileZilla now and it seems to be OK. Using this I can't transfer form one remote location to another directly so I am storing the files on my local machine temporarily. I'm seeing the following in the output even everything seems to copy ok:

Error: Connection closed by server
Error: Disconnected from server: ECONNABORTED - Connection aborted
  • No idea, but maybe trying another client (like FileZilla -- filezilla-project.org) can at least tell you if it's related to SmartFTP or not. – Arjan Nov 9 '09 at 19:32
  • Aha, and what when using SmartFTP to do the same as FileZilla then? (So, transfer via your local disk rather than using FXP like you did earlier.) – Arjan Nov 9 '09 at 22:18
  • Those errors are fine, just a tad annoying. Just means your connection broke, but was reconnected automatically. – Phoshi Nov 10 '09 at 20:51
  • Did you have any chance to test using SmartFTP the same way you're using FileZilla? (So, no direct FXP transfer from one remote to another.) – Arjan Nov 14 '09 at 10:22

PASV mode is definitely a good thing to try. Also, try using SFTP instead of just FTP (it's a good idea, generally).

Finally, take a peek at the logs on the server you are connecting to. There may be some good information there.

  • Same question as above... How would that explain that transferring a few files is fine, before the router blocks? And why would a router need a restart after that? – Arjan Nov 14 '09 at 10:14

Make sure your FTP client is transferring in passive mode if behind a firewall. Or try forwarding port 20 to your machine from the router (which is the transfer port for FTP).

Not really sure why this would kill your connection to the router, unless you router has some anti-attack setting or something and it doesn't like FTP.

  • But how would that explain that transferring a few files is fine, before it blocks? – Arjan Nov 10 '09 at 18:56
  • I've also seen routers that just die after transferring on FTP. Thought it was a cheap NetGear router, we eventually replaced it with a linksys and it cleared up the problem. – Jack B Nimble Nov 10 '09 at 20:25

See http://www.smartftp.com/support/kb/what-is-fxp-f14.html

I'm guessing one of the requirements isnt being met. Specifically:

  • Both FTP servers must support FXP and have it enabled. Please consult with the server administrator since most FTP servers do not support FXP, or have FXP disabled due to potential security risks.

  • One server has to support PASV mode and the other server must allow PORT commands from a foreign address. The client logs in to both servers and then it arranges for a file transfer by telling one server that it will be a passive transfer and the other that it will be an active transfer.

  • Same question as above: how would that explain that transferring a few files is fine, before it blocks? – Arjan Nov 10 '09 at 21:37
  • I recommend looking in the logs of both the servers in question. I'm guessing the receiver is limiting the number of concurrent files to something smaller than the sender expects, or maybe it's a timing problem, where the sender is expecting things to move faster than they do. Lastly this could be content-related; if you've only ever tested with the same set of files, try an entirely different set (say, a few dozen small text files) and see what happens then. ...Hope this helps! -pbr – pbr Nov 12 '09 at 19:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.