7

I'm having an issue using a keyboard which is not an English US keyboard. It seems that when it's the case, pressing AltGr key will simulate CTRL + ALT on Windows. I have verified that fact using Windows' on-screen keyboard in which pressing AltGr highlights Control and Alt.

Rather than trying to change Windows behavior, which would be tedious because I'm using two layers of Windows (Remoting with RDP from Windows to the Remote Windows Host, then using the Linux VM Guest), I would like to change the linux keymapping to understand that my level3 key switch is Control_L + ISO_Level3_Shift.

When using xev, I get the following output for pressing and releasing AltGr:

KeyPress event, serial 33, synthetic NO, window 0x4000001,
    root 0x108, subw 0x0, time 4346182, (158,441), root:(163,557),
    state 0x2010, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 33, synthetic NO, window 0x4000001,
    root 0x108, subw 0x0, time 4346182, (158,441), root:(163,557),
    state 0x2014, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
    XKeysymToKeycode returns keycode: 92
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 33, synthetic NO, window 0x4000001,
    root 0x108, subw 0x0, time 4347382, (158,441), root:(163,557),
    state 0x2094, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 33, synthetic NO, window 0x4000001,
    root 0x108, subw 0x0, time 4347384, (158,441), root:(163,557),
    state 0x2090, keycode 108 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
    XKeysymToKeycode returns keycode: 92
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

My keyboard layout is French Canadian. I'm using CentOS 6.4 with Gnome Desktop, and the Keyboard Layout Options, section "Key to choose 3rd level" doesn't not have Left Control available in it.

Thanks ^^;

3

This happened to me, here's what I did:

In the Oracle VM Virtualbox Manager (where you see the VM's  you have)
File
Preferences
Input
Disable 'auto capture keyboard'. 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.