3

I am trying to set up CUDA 5.5 on a laptop with Ubuntu 13.10 and Nvidia GeForce GT 645M on board. I've managed to get the card working perfectly fine with bumblebee and newest drivers. The problem emerges when I try to install CUDA.

First I tried to add a repository using the .deb file for Ubuntu 12.10 (seemed to be the closest one to what I would need on 13.10), did apt-get update and then ran apt-get install cuda-5-5 but I only got an error:

The following packages have unmet dependencies:
 cuda-5-5 : Depends: nvidia-current (>= 319.00) but it is not going to be installed
            Depends: nvidia-current-dev (>= 319.00) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

which seems a bit odd because as far as I am concerned nvidia-current doesn't exist in a version newer than 304.

At this forum I found a suggestion to use the .run file instead. I followed the attached guide and unfortunately failed again:

***WARNING: Incomplete installation! This installation did not install the CUDA Driver. A driver of version at least 319.00 is required for CUDA 5.5 functionality to work.

Both of the approaches didn't produce any good results with neither nvidia-319 package available in 13.10 repositories by default nor with nvidia-331 from the ppa:xorg-edgers/ppa repository.

Any suggestions on what I could try next to get things to work?

2

I think that your problem with CUDA might be that the CUDA package for Ubuntu 13.10 isn't working properly with the driver for your Nvidia graphics card. In Ubuntu 14.04 there is a new CUDA package that is not available in Ubuntu 13.10 called libcudart5.5. libcudart5.5 is the NVIDIA CUDA runtime library. This may be the CUDA package that you are looking for.

Here's how to enable CUDA with an NVIDIA graphics card. In Ubuntu 14.04 you need to install the nvidia-331 graphics driver or more recent in order to enable CUDA. You also need to install the NVIDIA CUDA runtime library. The Compute Unified Device Architecture (CUDA) enables NVIDIA graphics processing units (GPUs) to be used for massively parallel general purpose computation. Remove the existing proprietary NVIDIA driver and then open the terminal and type:

sudo apt-get install nvidia-331 libcudart5.5  

Then open Blender and select File -> User Preferences and it will open a Blender User Preferences window where you can check if CUDA is enabled in Blender.

enter image description here

| improve this answer | |
  • 1
    I heard Nvidia and Optimus will be better in Trusty. For now I would hold off on CUDA packages on Ubuntu because they may break and require you to re-install a bunch of graphics stuff from command line: bugs.launchpad.net/ubuntu/+source/unity/+bug/1268211 – NoBugs Jan 16 '14 at 2:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.