0

I am trying to install Apache2 on a virtual server. I installed apr, apr-util and pcre.

Then when trying to install apache, the ./configure thing work but when i try to make I get this error: libtool: link: cannot find the library /usr/local/apr/lib/libapr-1.la' or unhandled argument/usr/local/apr/lib/libapr-1.la'

To configure I typed this: ./configure --prefix=/data/home/afora001/php-apache/apache/ --with-apr=/data/home/afora001/php-apache/apr/ --with-apr-util=/data/home/afora001/php-apache/apru/ --with-pcre=/data/home/afora001/php-apache/pcre/

I don't get why it's trying to find a library in /usr?

Thanks! What am I missing?

  • Did you install the "-dev" variants of those packages. Reading the install guide in apache provides the following insight: "On some platforms, you may have to install the corresponding -dev packages to allow httpd to build against your installed copy of APR and APR-Util." – Carlos Nov 29 '13 at 23:56
  • Where did you read that? And where can i find those? I don't see any -dev packages here apr.apache.org/download.cgi – user3050890 Nov 30 '13 at 1:23
  • Well, I assumed when you stated that you "installed apr, apr-util and pcre" that you used your OS's package manager to do so. If you did, you would need to install the "-dev" variant of those packages. If you didn't and you compiled from source, then you need to do the following: "Make sure you have APR and APR-Util already installed on your system. If you don't, or prefer to not use the system-provided versions, download the latest versions of both APR and APR-Util from Apache APR, unpack them into ./srclib/apr and ./srclib/apr-util and use ./configure's --with-included-apr option." – Carlos Nov 30 '13 at 1:52
  • All this information is found in httpd.apache.org/docs/2.4/install.html under Requirements. – Carlos Nov 30 '13 at 1:53
  • You are right, I don't know how I did not see that. It seems to be working now. Thanks – user3050890 Nov 30 '13 at 2:27
0

Well, I assumed when you stated that you "installed apr, apr-util and pcre" that you used your OS's package manager to do so. If you did, you would need to install the "-dev" variant of those packages. If you didn't and you compiled from source, then you need to do the following: "Make sure you have APR and APR-Util already installed on your system. If you don't, or prefer to not use the system-provided versions, download the latest versions of both APR and APR-Util from Apache APR, unpack them into ./srclib/apr and ./srclib/apr-util and use ./configure's --with-included-apr option."

  • Yes that's what I did and it worked :) thanks! – user3050890 Dec 4 '13 at 3:16
  • Glad it worked out for you. Please tick the check next to my answer, greatly appreciated. – Carlos Dec 4 '13 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.