1

I am trying to install FreeBSD from a pen drive. But it returns an error on boot.

cd9660 :/dev/iso9660 error :/dev/iso9660/FREEBSD_INSTALL failed with error 19

and appears

mountroot>

command ?

List of GEOM managed disk devices:
    MSDOSFS/multiboot da0s1 da0 ada0

I've tried, but without success.

ufs:/dev/da0s1
ufs:/dev/da0
ufs:/dev/ada0
cd9660:/dev/da0s1
cd9660:/dev/da0
cd9660:/dev/ada0

Any ideas to solve this?

2

Some time ago I ran into the same problem. Luckily, I wrote down the solution.

At the loader prompt, enter:

 set debug.acpi.disabled="hostres"
 boot

This worked for me. Alternatively, I am told you can insert this line

 debug.acpi.disabled="hostres"

into the file /boot/loader.conf, but I never tried it.

In any case, you may look up this FreeBSD Manual page .

0

Try mounting the file system as read-only

eg. cd9660:/dev/da0 ro

worked for me.

0

Could be broken ISO downloaded or on the host. I have got same error 08-19-2015 FreeBSD 10.2 disc1 64bit, disc1 386 and even DVD

3 badly downloaded iso's would be rather odd? I think the problem is dev-side/host-side. Tried to load 10.2 on 3 differen machines(usb cdrom and ata cdrom) also on virtualbox(ata). On machine with usb cdrom it ends up with this error 19 on ata turns off the pc power 1 second after mount attempt. On Virtualbox crashes it. https://forums.freebsd.org/threads/52791/

I had succesfully installed FreeBSD 11 30-12-2015 on virtualbox. It's even simpler and faster install than PCBSD(TruOS).

0

So ran into the same problem, swapping to a different USB port appears to have "fixed" the problem. Initially, I had been trying with a USB3 socket.

2
  • 1
    Welcome to Super User. Can you add more detail about your situation? If there was a bad USB port, switching to another could be the solution, but the original being USB 3 should not have been a problem. So it isn't clear what part of your solution was actually the solution. – fixer1234 Jul 10 '19 at 0:14
  • So the only thing I changed was the USB port being used. To the best of my knowledge, all USB ports were working as expected prior to my attempts at installing FreeBSD. If it helps, here are some details about the laptop: - Its a second hand Toshiba Satellite C50D-A-138. - It previously had Centos7 running and prior to that it had Windows8 If you know of any ways I can test the USB ports from FreeBSD I am happy to give them a go and post the results. – Strider2009 Aug 18 '19 at 12:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.