9

I upgraded my Windows hard drive, and now have a space problem.

I inserted a new 240GB SSD, used CloneZilla to clone my old 120GB Windows C: drive SSD to this new one, switched the SATA cables, and turned on the computer.

Everything works great with the new SSD being the C drive, but it shows the old hard drive's space for some reason in Windows Explorer, while in Disk Management it shows the correct space. I restarted the computer and it was the same thing. Does anyone know what's going on?

Here is a screenshot of the issue:

Screenshot
(Click image to enlarge)

2
  • That is weird. :) Couple questions. What are those green checkmarks in the Explorer window? And have you tried using CHKDSK to check the file system condition? If you unhook the old SSD from the system does the new disk's size behave any differently? Nov 30 '13 at 4:19
  • I don't have enough rep to answer this question so that's why I'm commenting a solution. I spent 2 days trying to solve this problem. I tried all of the solutions below but what helped me was the following: I downloaded the software at partitionwizard.com. I moved my recovery partition to the end of the drive, then I was able to extend the C: drive into the remaining space. I hope this helps someone bc this pops up first on Google. Mar 21 at 20:16
12

No need for external tools. You can fix this issue by using the diskpart tool from command line. First open up the command prompt window. Then type diskpart to start the tool.

Within the tool use the following commands to extend the file system of the disk in question.

list volume
select volume #
extend filesystem

Replace the # with the volume number that you see after entering the list volume command.

4
  • 7
    If this does not work right away. Try shrinking the partition first, then windows should find the "lost" disk space. You can then expand the partition to the full size, using either diskpart or the disk management GUI.
    – akimsko
    Dec 11 '18 at 21:47
  • @akimsko your suggestion worked: after shrinking volume with 1MB Disk Management could suddenly see the lost 500GB. Afterward I could then extend it with 500GB. No need to run the diskpart May 30 '19 at 10:08
  • @akimsko You should post that on the actual CloneZilla forum!! Dec 21 '19 at 9:22
  • @nick-painter solution worked for me as is. Many thanks to you! You saved my time
    – Denis
    Dec 11 '20 at 7:28
11

When you clone a partition, you clone EVERYTHING even the size.

Download a copy of GParted Live CD. Burn it, boot off of it and EXTEND the partition on your 240 GB SSD. This should take no more than 10 minutes, tops. Given that you have a backup of your data on your original drive, I think you have all your bases covered. Good luck!

4
  • 1
    Gparted shows the 100mb boot partition + 223gb c partition just like windows disk management. only windows itself shows the old sizes for some reason. i.imgur.com/PUwm2pS.gif
    – themike
    Nov 30 '13 at 3:14
  • I suspect the problem will then be the filesystem on the disk. You would need to find a way to "grow" it. Have a look at askubuntu.com/questions/72344/…
    – davidgo
    Nov 30 '13 at 4:17
  • Correct, davidgo. Hence, OP needs to get gParted Live CD, boot it and extend the NTFS partition.
    – Carlos
    Nov 30 '13 at 6:19
  • After using CloneZilla to clone a 256Gb to a 1Tb SDD, I was only able to get Windows to recognize the full size by booting GPartEd Live, which offered to "fix" the partition table on launch. After that I created an new NTFS partition in the unallocated space and then booted back to Windows.
    – Mr. Bungle
    Nov 17 '18 at 16:47
2

In Windows Disk Management right-click the volume you want to extend. Select Shrink Volume... and shrink by e.g. 1MB. After shrinking Disk Management now sees the missing 120GB data volume. Right-click and select Extend Volume....

Solution provided by @akimsko as a comment. Elevating it to a proper answer.

1

Just an add-on to what was said about using windows disk management. The easiest and quickest way is do a drive shrink, but only shrink a very small amount like 10MB. If you do a large amount, it could take for ever to do. So shrink 10MB, it should do that instantaneously, and then the remainder of the drive will appear and you can then do the extend.

1

What is required is simply after cloning to drop into the command line, then run the command "sgdisk with the option -e" eg) sudo sgdisk -e /dev/sda, then a new partition can be created with "sudo cfdisk /dev/sda", move down to the free space at the end of the disk, then choose New, take defaults and normal 'dows partition software will see available space and a deleteable partition.

I hit this problem and finding the common Windows utility offerings too vague and unsure if Samsung's migration utility would allow me to clone via images on an intermediary USB drive, I chose using Clonezilla which worked a treat accepting the defaults having created a directory on the USB disk for the images.

There were text warning messages from various partition utilities, about the cloned GPT NOT being the correct size and needing fixing, but they scrolled by quickly.

Thanks to Arch Linux for documenting "How to Expand a GPT Table to Whole Disk", a far faster more elegant solution once Clonezilla has copied the disk or partitions. [ See https://wiki.archlinux.org/index.php/GPT_fdisk#Expand_a_GPT_disk ]

Clonezilla is excellent but focussed on those with Linux experience, there are Linux ditros with graphical interfaces which would have done the job. IF I could have simultaneously connected both old SATA SSD and the MSATA card mounted in an MSATA->SATA pass through adapter 2.5" caddy made by Sabrent, I wouldn't have needed Clonezilla's flexibility. It saved me fitting both disks into a desktop machine where I could clone and fix the GPT directly. I was getting about 3GB/min over USB, so the imaging & restoring were far quicker than similar restores under W10

0

Thanks for the answers everyone, but I solved this by re-cloning the partition but not with Clonezilla, but using Intels data migration software from here: https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=19324

Was 10000000x easier than clonezilla since you set it up in windows, it restarts, and does its thing. I guess for easy tasks like simply cloning that's the way to go. took 20 minutes and the partition shows the correct size in windows now, yay.

1
  • Just a note, the software at the download link only works if you have an Intel drive.
    – Mr. Bungle
    Nov 17 '18 at 16:48
0

Go to Disk Management. Right click on "unallocated space and format as NTFS. You will get your remaining space as a new partition.

Not the answer you're looking for? Browse other questions tagged or ask your own question.