6

For the past week or two I've been having an issue where apps will say that my Hard Drive is full (not the startup drive, the one where my home directory is). iMessage is saying "Disk Full. Messages may be lost" and Spotify is saying "Unable to save to cache. Maybe the Hard Drive is full". The Mac sometimes stalls for extended periods of time (10 seconds+) while opening a file etc.

Looking in Disk Utility, all of my hard drives have adequate space (75GB on the HD in question). But I've just launched it now and it switches between 75GB and 148KB (so there's obviously an issue somewhere). I've ran Disk Repair on it but that found no issues. What else can I try?

  • 3
    I'm not on a Mac right now to check if this still exists, but there used to be an option to erase free space - which solved an issue like that for me in the past. – nerdwaller Nov 30 '13 at 16:22
  • That's still an option - just running it now :) – Alex Blundell Nov 30 '13 at 16:25
  • 1
    Hope that works! I just pulled mine up to verify, I've seen it reclaim a ton of space (even though it technically was already free). – nerdwaller Nov 30 '13 at 16:25
  • I think it worked! I'll have to keep an eye on it because it was an intermittent issue, but so far no errors. Thanks :) – Alex Blundell Nov 30 '13 at 18:56
  • If this ever happens again, you might want to try a tool like WhatSize to find out where the missing space is. – Elliott B Dec 4 '13 at 23:15
1

Just to wrap this up for others looking for the answer, you can go to Disk Utility and find the command that cleans this up:

enter image description here

0

If you have a Time Machine backup configured, Mavericks will use free space to create local, temporary snapshots between full backups to the external drive. I have my Home folder on a different HD than the startup disk and Time Machine used my startup disk for local backups but that may depend on exactly how you split things up.

See this apple kb for more info.

You can disable this functionality using instructions here (osxdaily).

-1

I had the same problem. It was related to Safari having a corrupt DB and by ApplePushService. open Console and check the errors to confirm this. If so, clear history and website data through Safari itself (or by Terminal) and turn off Notifications (google the steps) to solve the issue. Shutdown and Boot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.