4

I recently purchased Lenovo Thinkpad T440s which the touchpad is one big button. I am trying Ubuntu 13.10 on this machine.

How do I disable the 'touch' on the touchpad without disabling the clicking? I would like to use the trackpoint for moving the cursor and the touchpad for clicking.

Here is what I see in xinput list:

ubuntu@ubuntu:~$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=11   [slave  pointer  (2)]
⎜   ↳ TPPS/2 IBM TrackPoint                     id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Integrated Camera                         id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=10   [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                    id=12   [slave  keyboard (3)]

Ended up doing:

/etc/X11/xorg.conf.d/50-synaptics.conf:

Section "InputClass"
        Identifier "Default clickpad buttons"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "60% 0 0% 25% 40% 60% 0% 25%"
        Option "AreaBottomEdge" "0%"
EndSection
2

You can put :

Section "InputClass"
    Identifier "t440 top buttons"
    MatchDriver "synaptics"
    Option "SoftButtonAreas" "60% 0 0 0 40% 60% 0 0" #Emulate right and midle buttons
    Option "Synaptics Area" "0 0 0 1" #disable moving but not buttons
EndSection

In /etc/X11/xorg.conf.d/99-t440-synaptics.conf

My source for emulate right and midle buttons is here : http://who-t.blogspot.fr/2013/12/lenovo-t440-touchpad-button.html

I still search a solution to combine middle button + trackpoint for scrolling :(

  • Same! Also looking for way to use the middle button for scrolling! – user1501961 Aug 4 '14 at 1:52
0

Took an arch patch, applied it on a debian package, and installed it on Ubuntu (Mint). Solves your problem as well as trackpoint scrolling.

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/1246683/comments/40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.