I want to be able to get a script (ran at startup) to open up a konsole terminal.
When it opens it is to do some persistent things (like change directory and source bashrc) and run a long running program.
If the program crashes or I come in and <ctrl+c> it, it is to start accepting commands from standard input (like 'up-enter' to try again, as if it was interactive the whole time).

I have tried so many things to get it working (I'm currently just trying to get it to ls and revert to interactive on completion);

konsole -e ls
konsole --hold ls
konsole -e /bin/bash -c ls
konsole --hold -e "/bin/bash -c ls"
konsole -e "/bin/bash -i -c ls"
konsole -e /bin/bash -i -c ls
konsole -e "echo ls > /tmp/konsolebash;/bin/bash -i --rcfile /tmp/konsolebash"

echo ls > /tmp/konsolebash
konsole -e "/bin/bash -i --rcfile /tmp/konsolebash"

Is it to do with the quotes? Should I not be using them, should I be escaping something?
Am I even meant to try and execute bash?
I'm running out of ideas but I hope it's even achievable (but hopefully not something embarrassingly simple that I missed).

I'll upvote answers that successfully use other terminal emulators if konsole in particular is the problem (but since the question is specifically about konsole I don't think I can give you the juicy tick)

  • The last two lines look promising. Have you tried them without escaping the quotes around source ... ls?
    – n.st
    Dec 2, 2013 at 1:06
  • sorry that was a copy paste error from writing the question
    – Hashbrown
    Dec 2, 2013 at 1:09
  • And that didn't work? Strange... What exactly did it do?
    – n.st
    Dec 2, 2013 at 1:09
  • yeah it just brings up a normal interactive shell (no command is visibly ran, just prompt is displayed). It seems to either accept arguments, or be interactive, never both.
    – Hashbrown
    Dec 2, 2013 at 1:10
  • 2
    I still think however that using --rcfile should have done exactly what you need... Edit: In fact, I just checked and bash --rcfile /tmp/foo does work for me, while bash refuses to start with -i --rcfile /tmp/foo. So try omitting the -i and see if that helps.
    – n.st
    Dec 2, 2013 at 1:31

2 Answers 2


Thanks to @n.st's comments I have made this one liner:

konsole -e /bin/bash --rcfile <(echo "cd /;ls;echo hi | less")

Which is just a shorter version without tmpfiles, using bash process substitution for the following;

echo "cd /;ls;echo hi | less" > /tmp/konsolebash;konsole -e /bin/bash --rcfile /tmp/konsolebash

Which will run some commands, have them display, change the environment, run a long running program (less) and when it ends (:q) will be interactive.
So replace cd /;ls;echo hi | less (the demonstration) with your script.

No history but at least you're in the correct directory now and have any environment variables you may have wanted set up.

Basically the same as my prior attempt;

konsole -e "echo ls > /tmp/konsolebash;/bin/bash -i --rcfile /tmp/konsolebash"

except the file write is outside the konsole execution, I've dropped the -i flag and the execution parameters are not in one quote block

Unfortunately the --rcfile switch causes your ~/.bashrc not to be loaded for those commands, so if you needed an alias or something you'll have to do this;

cat ~/.bashrc > /tmp/konsolebash; echo "commands" >> /tmp/konsolebash;konsole -e /bin/bash --rcfile /tmp/konsolebash

Which just copies your bashrc then appends your commands to the end of it

  • There is no need to copy your bashrc, just use source ~/.bashrc.
    – n.st
    Dec 2, 2013 at 11:21
  • I actually tried that, it doesn't work for the rest of the commands in the list. I.e if .bashrc has alias BOB, the argument source ~/.bashrc;BOB;cd / will have BOB fail. I have no idea why, but this works
    – Hashbrown
    Dec 2, 2013 at 12:10

A shorter & simpler solution:

konsole -e '$SHELL -c "ls; $SHELL"' &

This one doesn't have the issues with history or sourcing .bashrc either. If your $SHELL environment variable doesn't point to bash, you can specify it manually.

This does spawn a second (bash) shell inside the same terminal window, so some things from the first command might not be carried over.

Answer adapted from an askubuntu answer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .