28

I am using Windows 7 x64 and have installed the SetPoint Settings software and have specified OS implementation. I have also unchecked the smooth scrolling.

How to fix this problem, so the response will match the actual scrolling of the scroll wheel ?

10 Answers 10

39

Try pushing down on the scroll wheel, it should click. I just discovered that the wheel toggles between a very smooth scroll and a more precise scroll. In my case, changing to the more precise scroll fixed the problem. It makes the scroll feel more like a gear than a roller ball. I think with the very smooth scroll, it tends to keep rolling and "bounce" around a bit at the end of a scroll.

8
  • 1
    This really helped me; my mouse was moving all over the place, even if i picked the mouse up and moved it, the wheel was causing a scroll event! Thanks a lot!!
    – Dan
    Jul 7, 2015 at 14:45
  • 11
    Mine had a toggle button just below the scroll wheel I needed to push. It now acts as a gear with ridges. That fixed it for me.
    – Dan
    Jul 5, 2016 at 14:46
  • 1
    Experienced the same problem, the mouse had two different scroll modi. I had a button below the wheel to switch modi.
    – skubski
    Dec 20, 2016 at 10:19
  • 2
    This answer only shows you how to disable the fast scroll, most of us are coders here, who would want the fast scroll disabled? Im thinking of instead of cleaning it, getting it dirty, so it wont scroll every time I move it, because it doesnt do it when i hold my finger on the wheel and shake it, but it does do it when i just shake it. I suspect the wheel is out of balance, and the scroll is too smooth. Maybe it will not move to gravity after it gets a bit worked in. maybe some thicker grease to slow it down.. Oct 2, 2017 at 19:07
  • 2
    I bought two new Logitech mice of different models and both have the same exact problem. This is due to the fact that the wheel's weight is not evenly distributed. Toggling the scrolling mode is not a solution. The solutions I have found so far on the Internet are (1) open the mouse and put a hole on the wheel to reduce the weight of that part (2) insert a wire so that it touches the wheel slightly to prevent spontaneous rotation. The second solution may reduce the free spinning speed, though. Curse Logitech for not acknowledging/solving this problem. Jan 25, 2019 at 17:55
6

I've had that kind of problems before, with a cheap mouse. The problem has to be in the scroll wheel, and opening the mouse with a little cleaning and checking the moving parts would help. Of course, if you are willing to go into that. Depending on the mouse, it may be hard to do, or nearly impossible without inducing damage.

6
  • 5
    Wonderful, just blowing in the wheel a little helped! It must have been a bit of dust in the mechanism. Many thanks. Dec 2, 2013 at 23:49
  • There you go, I'm glad you got it working ! ;) ( p.s.: setting my post as good answer would help with my newbie status ;) )
    – James C
    Dec 2, 2013 at 23:50
  • Thanks a lot but actually, the problem came back very soon after... :( Dec 5, 2013 at 0:06
  • 1
    Here's what helped me. I have put a tiny bit of oil to the rotating part of the scroll button, where it has friction with the case holding it. I don't know how that oil is called in English, but it's a very "generic" one for that kind of use, I use it when computer cooling fans get rusty too. And other thing, check the opening at the bottom of the mouse, where IR sensor is. My mouse lets a lot of air ( and thus dust too ) go inside from there. Try seal that opening from the inside of the mouse, without covering the sensor in any way. And of course, be careful with handling.
    – James C
    Dec 5, 2013 at 0:21
  • 4
    Blowing in the wheel with compressed air has fixed my Anywhere MX, wonderful. :)
    – RushPL
    Aug 24, 2014 at 11:25
1

I had the exact same problem on my Win 7 x64 after installing Logitech SetPoint. The problem only occured in my web browser though. Thought I'd mention it anyway since no other has, and the requestor didn't mention if problem occurs everywhere or in browser only.

I never noticed during the SetPoint installation, but it actually installs an addon (atleast for Firefox), and that damn addon apparantly creates scroll issues.

So my solution was to simply disable Logitech SetPoint addon in your browser and it worked perfectly again.

1

Ok There're 2 solutions:

  1. click wheel to switch to gear mode.

  2. still use free mode but set scrolling at a time to minimum. (like user:ThreaT refer)

Solution 2 is not fix your problem but change the way you using mouse. Now you can scroll a lot will smoothly stop. A little bit scroll back won't impact you a lot.

0

My 2017 Darkfield has a button behind the scroll wheel that toggles on and off. If you click it, it suspends the extraneous scrolling.

1
0

I think this is because the scroll wheel is imperfectly balanced due to manufacturing problems, so it always tends to rest towards a certain direction due to the lack of damping, similar to what this video shows: https://www.youtube.com/watch?v=z2Fj25YO7AQ

Currently I'm looking for a solution for my Mx Anywhere 2s too, but I think my best chance is simply to return it and swap for a new one. This behaviour should be classified as faulty I think.

2
  • 2
    Given how many people are mentioning the same problem, it is probably not some isolated minor faulty units, but a common problem that Logitech ignores, like that Apple is saying bent iPad is "normal". A lot of people here and there are suggesting to toggle the scrolling mode to ratcheted, but that is not a solution. It is a mere workaround, and keep toggling it is not convenient at all. Your solution of keep returning until you get the good one, will not work in my country. Here, you cannot return a unit that is opened, without a proof that the device is faulty. Jan 25, 2019 at 17:49
  • I guess I was fortunate that I bought it in Australia and was able to return it and get a new one. And fortunately the new one does not have this problem. If you are really desperate, you can try to apply a relatively large force on the scroll wheel to deform it to re-balance the weight. I read this method somewhere online but didn't try it; no guarantee that it works.
    – Alan Wang
    Jan 26, 2019 at 8:30
0

MX Vertical you need to double click the mouse wheel to switch between exact and smooth.

-1

You can change mouse wheel settings by going

Start -> Control Panel -> Mouse -> Wheel

enter image description here

Decreasing sensitivity may resolve the issue.

-1

In my case my screen was scrolling/jumping. Pushing the scroll button usually fixes this but did not. Then I noticed it continued after i turned off the mouse. Voila! TUrns out it was the batteries in my bluetooth keyboard were low causing it to errantly activate the "home" button on the keyboard.

-2

I fixed mine. I had to open the mouse and click the free scroll button (normally under the wheel). It does not seem to fully engage when clicked via the provided button. But, when the mouse is opened, you can manually press the lever to engage it. Even then, it took several clicks, but it will re-engage.

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.