1

Trying to install ffmpeg on osx 10.8.5 using homebrew. If I perform a default install without optional stuff it installs just fine. But if I want to add an optional component it fails with the following message:

> s-se-sto-ed01:~ admin$ brew install ffmpeg --with-fdk-aac
==> Installing ffmpeg dependency: fdk-aac
==> Downloading //downloads.sourceforge.net/project/opencore-amr/fdk-aac/fdk-aac-0.1.2.tar.gz
Already downloaded: /Library/Caches/Homebrew/fdk-aac-0.1.2.tar.gz
==> autoreconf -fvi
/usr/local/share/aclocal/ogg.m4:8:   run info Automake 'Extending aclocal'
/usr/local/share/aclocal/ogg.m4:8:   or see http://www.gnu.org/software/automake/manual/automake.html#Extending-aclocal
autom4te: need GNU m4 1.4 or later: /usr/bin/m4
aclocal: error: echo failed with exit status: 1
autoreconf: aclocal failed with exit status: 1
READ THIS: https://github.com/mxcl/homebrew/wiki/troubleshooting

I have tried to reinstall autoconf using:

brew rm autoconf && brew install autoconf

I have searched high and low but so far I have not been able to find anything that will help me sort things out. I am quite new to homebrew.

1
  • fdk-aac is at 0.1.3. You can provide and accept your own answer so others know this question already has an answer.
    – llogan
    Dec 3, 2013 at 18:27

1 Answer 1

2

Turns out I did not have m4 installed. To get m4 you either need to install Xcode CLI tools. Open Xcode » Preferences » Downloads and install CLI tools — and hey presto!

I am not sure, but I think you can also install it using Homebrew, with brew install m4.

1
  • To the OP: this is your answer, if you want to post a real one yourself, just go ahead and let me know.
    – slhck
    Dec 4, 2013 at 7:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .