4

I repaved my laptop over the Thanksgiving weekend with Windows 8.1, installed from a DVD.

Full disclosure - I did do something not exactly approved - I interrupted the installation process and added a junction at the C:\Users directory to point it to U:\Users (U: is my second drive). I used robocopy to copy the installed DefaultUser and Public directories over to U:\Users.

I have created 3 different accounts: a local user ($dave) set up as an administrator account, a login through my Windows Account, and a Domain login (HQ\dave). The local administrator account and the Windows account both seem to to work correctly.

The domain user is unable to access any AppStore apps, including the app store itself, and it is unable to Change PC Settings: Clicking that choice under settings causes it to bring up a royal blue screen with nothing on it except the mouse pointer. There are only 5 tiles shown - Desktop, IE, File Explorer, App Store, and Sky Drive. App Store and Sky Drive don't work. (I wanted to connect the Domain user to the Windows account, but since that is done through the Change PC Settings menu, and I can't get to that, then I can't do that.)

The other symptom (possibly related, possibly not) is that, even though the machine is joined to the domain and I'm logged in as a Domain User with access rights to other shares on the network, any attempt to access a network file on one of the other machines asks for my network credentials. (This is blocking me from getting Outlook working because the mail file is on another machine, and it doesn't ask for credentials, it just fails.) I can open the network shares in the Explorer, but if I actually try to access a file, then it asks for credentials. I don't understand that one.

I have google'd a lot of articles on these subjects looking for a solution, and have not found anything applicable. I would be most appreciative of help from anybody that has seen and solved this problem.

Thanks.

  • The reason Windows Store apps are not working is because of the redirection. The network share problem is an entirely different program and really should be seperated from the Windows Store problem. – Ramhound Dec 3 '13 at 12:10
  • Thanks for your response, Ramhound. But if that's the case, why are the Windows Store apps working for the other 2 users (the local login and the MS Account login), which are also redirected? I'm willing to accept your answer, but I want to understand the reasoning behind it. – daveh551 Dec 4 '13 at 11:12
  • I do believe I have solved the network access issue: I had two DHCP servers running, one on the Domain controller, and one on the Netgear router. Depending on which of them won the race to supply DHCP settings, it might or might not have had a DNS server that could recognize the domain controller. Fixed that, and the network seems to be working better. – daveh551 Dec 6 '13 at 13:28
  • I didn't post the redirection comment as an answer, for a simple reason, while unsupported it is possible to get it to work but its extremely hard and required what is pretty much a permission hack in order to do so. Verify the permissions on the folder, for the user where Windows Store is not working, is the same as the folder for the users where it is working. – Ramhound Dec 6 '13 at 13:35
  • Well, for unknown reasons, I have resolved this issue. I started over one more time with a fresh install, and, this time, when I joined to the domain and logged in as the domain user, my AppStore tiles and apps worked, and I was able to change PC Settings. I'm not sure what I did differently, but the problem is fixed. (And, BTW, I still have my Users directory relocated to the second drive via a Junction link in C:\Users.) – daveh551 Dec 10 '13 at 12:49
1
  • Change the following registry key: HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages Set owner to SYSTEM
  • logoff
  • Reset the store: WSReset.exe
  • apply the above powershell line
1

I found this solution from Microsoft. It works.

Fixing file system permissions that have been changed manually

  • Open File Explorer
  • Browse to "c:\Program Files "
  • Right click and select properties
  • Select the "Security" tab
  • Click the "Advanced" button
  • Click the "Change permissions" button
  • Click the Add button
  • Click "Select a principal" link
  • Click the locations button and select the local computer
  • Add the All Applications Packages group name and click ok
  • Make sure that Type = allow and Applies to = This folder, subfolder and files.
  • Check Read & Execute, List folder contents and Read.
  • Check the box Replace all child object permissions with inheritable permission entries from this object
  • Click Apply and OK.
  • Repeat for c:\Windows
  • Repeat for c:\Users but grant the "All Application Packages" group Full Control.
  • Click Apply and Ok.

Fixing file system permissions changed by Group Policy

Have a Group Policy administrator do the following:

  • Open Group Policy Administrative Console
  • Locate the GPO identified in the step "Determining if Group Policy is being used to manage permissions"
  • Right click and select edit.
  • Go to the location Computer Configuration\Policy\Windows Settings\Security Settings\File System
  • If there is an entry for the paths already created you can edit it. If no entry exists create a new entry for each path.
  • To create a new entry right click file system and select add file
  • Browse to the path c:\Program Files, click OK
  • Select the Add button.
  • 1
    Where did you find these instructions exactly because they don't seem like something Microsoft would suggest besides the user already tried this via the power shell command – Ramhound Jan 31 '14 at 20:32
0

The fix is open a CMD window and type powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml

  • I typed the command as you had it, it executed with no error and no output, but also no change. Still can't Change PC Settings, still no Apps in Start Screen, still can't access AppStore or SkyDrive. – daveh551 Dec 6 '13 at 13:25
  • 1
    Not everyone on Super User is a Powershell expert. Although the command is self-explanatory enough, please consider editing an explanation into your answer. – Jonathan Garber Dec 6 '13 at 15:12
0

Check your network connection, if you have google DNS server try remove it or put your gateway IP. I had this before problem but after I remove google DNS server (8.8.8.8) and I changed it to my router IP it fix the problem and windows store started.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.