3

This question has changed drastically since the first time I posted it, so I have deleted the old content.

I downloaded the latest version of VMWare player and when I try to install it I get the following error in the console:

Gtk-Message: Failed to load module "canberra-gtk-module":
libcanberra-gtk-module.so: cannot open shared object file: No such file or directory

Then I get a windows saying:

One or more of your processors does not have the necessary 64bit extensions to run VMware virtual machines.

Notes: I have latest version of Kali linux, 32 bit operating system and architecture. I have the latest version of VMWare player for 32 bit architectures.

  • You must have your repos set up wrong, the headers for the kernel are in the repos. – MariusMatutiae Dec 3 '13 at 18:58
  • There is an answer for you. – MariusMatutiae Dec 5 '13 at 12:06
  • Hm, if I remember correctly, there should be also a logfile from the installer (/var/log/vmware-installer), perhaps this is more informative than the error you get on the console. – mpy Dec 5 '13 at 15:43
  • 1
    @Sniffer I have updated my answer with another try – MariusMatutiae Dec 5 '13 at 16:53
  • May I ask, why you are using such an "ancient" VM player version (dated 2010) on a recent linux (dated 2013) distro? – mpy Dec 5 '13 at 18:22
4
+50

It looks like you are missing an essential package:

  sudo apt-get install build-essential

Then try again, it should work this time.

Edit:

Try these two addiitons, pls:

 apt-get install open-vm-tools
 apt-get install open-vm-toolbox

Edit 2:

Did you try to install the two packages above? Also, it says here that VMWare player 4 is only compatible with 64-bit architecture.

The libcanberra error is an old nuisance I had too, it can be solved by adding a symlink,

  /usr/lib/libcanberra-gtk-module.so -> /usr/lib/x86_64-linux-gnu/gtk-2.0/modules/libcanberra-gtk-module.so

and then running (as sudo) ldconfig. Since you have a 32bit system, you should probably (you will have to check that this file exists, I do not have a 32 bit system to test this) symlink instead to

  /usr/lib/i386-linux-gnu/gtk-2.0/modules/libcanberra-gtk-module.so
| improve this answer | |
  • Thank you for responding. First of all I downloaded version 6 of the player from this link and there is clearly a version for 32 bits systems so I downloaded that. On the other hand I haven't tried to install the two packages you have mentioned yet. Finally I will create the symbolic link and get back to you with my latest findings. – Ibrahim Najjar Dec 6 '13 at 12:45
  • Do you have VMWare installed on your linux machine, what version are you using ? – Ibrahim Najjar Dec 6 '13 at 15:27
  • @Sniffer No, I prefer VirtualBox, which is far superior in connection possibilities. It has native NAT and Bridge, internal network, pre-configured DHCP server.... – MariusMatutiae Dec 6 '13 at 19:08
  • The problem is that the operating system I want to host is only available in a VMware image, otherwise I would have considered VirtualBox. Anyway thank you for all your help. – Ibrahim Najjar Dec 6 '13 at 21:43
  • @Sniffer any progress? – MariusMatutiae Dec 8 '13 at 8:24
2

Thanks for help from all the guys, After some digging around around, I downloaded VMWare Player version 5.0.2 which worked flawlessly and without any kind of errors and warning.

Both the latest version 6.0 and the older one 2.5.5 didn't work and caused hell of dependency problems and errors.

So if you are running kali-linux-1.0.5-i386 on 32bit system like me, I would recommend that you download version 5.0.2 of the player which should work without any problems.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.