13

Over some of my program shortcuts and install files, there is an uac icon overlay (blue-yellow shield) and I find them really ugly. Is there any way to get rid of them please?

Edit

I closed UAC to see if overlays go away or not. Now it's open. But maybe there is a way to remove them without closing the UAC like removing shortcut arrows in this question: Remove shortcut icon overlay from shortcuts on Windows 7

12 Answers 12

6

After days of trying various methods, I believe I've found the ultimate solution to remove that annoying shield icon; it's not difficult and works perfectly for me.

The following procedure removes the shield overlay only from icons and Start Menu items, but will not be removed from Control Panel applets and context menus.

  1. Disable UAC [User Account Control] by moving its slider to the lowest position
  2. Open Command Prompt (you'll find it in the Start Menu)
  3. Execute the following, pressing Enter after each line:
    TaskKill /IM "Explorer.exe" /F
    Cd /D "%LocalAppData%"
    Del "IconCache.db" /A
    Shutdown /R
    
    • Last command will restart the computer, so ensure you save your work before executing
    • If experiencing the shield icon again, execute the above again
3
  • Thanks, this worked perfectly. Also, I didn't need to restart the computer.. just run explorer.exe again. :)
    – LGT
    Aug 13 '16 at 14:36
  • 1
    UAC should never be disabled, as doing so is a massive security risk
    – JW0914
    Aug 27 '20 at 11:37
  • I didn't think this could help since the icon appeared on shortcuts created after I had long since disabled UAC, but apparently this cache stays around for a long time. Deleting the cache and restarting explorer.exe removed the shield from all icons, old and new.
    – Lilienthal
    Jun 4 at 17:56
3

I had this problem on my Firefox icon after running as administrator.

In order to fix it, I dissabled UAC and restarted PC. The shield icon had now dissapeared and then I reactivated UAC.

3

There is another way - create a transparent icon, run TuneUp Utilities and replace the User Account icon with the transparent one, that solves the problem and the shield icon remains in the context menu, but doesn't ruin your icons anymore. TuneUp can also remove the shortcut arrows with just one click and replace basically any icon.

3

Ok, there is a solution, though it's not exactly elegant. You can find more about it here, but the basic answer is:

Modify imageres.dll. Just clear UAC icon, make it transparent (and Shortcut overlay at one shot). A side effect is that admin icon is missing in context menu, where Run as Administrator command is. Personally I can live with it!

2
  • UAC icon has index 78 in imageres.dll, if it helps. It would have been better if there was a link to it in the Registry, so it could be changed without modifying imageres.dll, but I couldn't find one.
    – Snark
    Nov 10 '09 at 12:02
  • 1
    Personally, I wouldn't change the icon. But the method above is rather easy and it does not involve stopping UAC...
    – alex
    Nov 10 '09 at 12:53
2

I was able to remove the blue & yellow UAC shield icon from in front of one of my desktop icons by right clicking on the icon, scrolling down, selecting properties, selecting shortcut, then change icon, then you should see your original icon in that window, double click the icon and hit OK. Now it should return back to the original Desktop icon without the UAC icon in front. I hope this has helped...

2

Why go through all that trouble?

  1. Enable the option View hidden files and folders
  2. Rename %LocalAppData%\IconCache.db or create a new folder (place IconCache.db within it)
    • If you don't want IconCache.db at all, delete it
  3. Hide system files and folders again
1

In most cases, the Windows Defender shield on desktop shortcuts is due to old applications or applications with questionable compatibility and there's no need to compromise Windows Defender to eliminate it:

  1. Paste the following vbScript into a text editor, change file path and .exe name, saving it in the application folder as Whatever.wsf
    <job>
      <script language="VBScript">
         Set oShell = WScript.CreateObject("WScript.Shell" )
         oShell.Run("""c:\users\%username%\my apps\dividing head setup\dividing head setup.exe"""), 0, true
    
         Set oShell = Nothing
      </script>
    </job>
    
  2. Right-click on Whatever.wsfSend to Desktop
  3. Go to the Desktop, right-click on the resulting shortcut, and choose PropertiesIcon
  4. Browse to the .exe from step 1 → OK

Enjoy the new shortcut icon without a shield

0

I have three drives on my machine (two SSD and one 'normal') This shield only appears on some programs that are on my C drive. By moving the programs to either of the other drives, the shield dissapears. Of course this fact is only useful if you ave two drives !!

0

I believe I have solved this problem of the ugly blue and yellow shield.

I don't really understand why Windows 7 has two program files folders within C: , but I thought I would go ahead and install Firefox into %ProgramFiles% and not %ProgramFiles(x86)%:

  • Choose Custom Install, → Change install location to %ProgramFiles%

All icons were normal and did not have a shield over them.

1
  • 4
    You have two program files folders because you are running a 64 bit version of Windows 7. The program files(x86) is for 32 bit applications and the regular program files directory is for 64 bit apps, it's just a method for organization between apps. Oct 4 '10 at 19:19
0

A possible solution is to use NirCmd.exe to call the target application:

  1. Download NirCmd and copy it into %WinDir%
  2. Right-click the shortcut you want to get rid of shield symbol on → Properties
  3. Change icon...OK, even though changes were not made (just do this step!)
  4. Add NirCmd elevate at beginning of the target application path → OK
    NirCmd elevate "%ProgramFiles(x86)%\Photoshop CS6\photoshop.exe"
    

The shield symbol is gone and the Admin rights will remain for the target application due to the command nircmd elevate.

0

The shield is indicating the shortcut has been configured to run with Administrator privileges

To change it and get rid of the shield:

  1. Right-click on the shortcut → Properties
  2. Advanced... → Un-check Run as Administrator → OK → Reboot your computer
    (To run as Administrator: Right-click shortcut → Run as Administrator) Screenshot

Once rebooted, the shield should be gone and the program should run normally

0

I had the same problem with the shield on some icons, but I found a way around it without using any other software or registry editing.

The way to do it is simple - say you have a MS Word doc on the Desktop with a shield on it:

  1. Delete it from the Desktop → Go to where the MS Word folder is and open it
  2. Right-click on MS Word and create a shortcut in the same folder
  3. Right-click on the new shortcut → Send to Desktop
1
  • Can you please stop shouting? Not gonna edit this so that you learn it.
    – Ray
    Nov 2 '14 at 9:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy