5

I've had git running on my machine for over a year. I have a folder in my C root called gitRepo, which contains all my various repos. For some reason, for one repo only, the git bash command is suddenly missing from the right-click context menu. Here's a screenshot from a working repo: enter image description here

And here's the "non-working" repo: enter image description here

The git bash command is missing from the non-working one. (Yes, I know I can open a bash window from the working one, and then just use cd ../ to change directories so I'm in the correct repo, but that's just asking for trouble, as I frequently have bash windows open for multiple repos.)

What isn't visible in the screenshot is that the entire top menu chunk (Open - Play with VLC media player) is also missing from the "bad" repo; the only item available in that top chunk is 7-Zip.

What could have caused this, and how do I get the entry back?

5 Answers 5

4

Even if the context menu is working correctly otherwise, it doesn't appear if you go to a folder via your "Library" in Windows. So when doing that, use a direct path from C:\ onwards instead.

3
  • 1
    Where does it say anything about going from the Library folder?
    – EmmyS
    Commented Aug 27, 2015 at 18:41
  • Future visitors might very well be doing that, @EmmyS? (And Super User and other Stack Exchange Q&A sites are very much intended to help future visitors too.)
    – Arjan
    Commented Aug 27, 2015 at 19:17
  • 2
    This is what happened to me. Does anyone know why this is happening, and if there is a way to make it work from the library folder?
    – crush
    Commented Jan 23, 2017 at 15:33
2

This may not be an option for everyone, but here's what finally worked for me. Since I knew that newly-created folders would have the correct context menu, I just renamed the "bad" repo (just to be safe), then created a new clone of the remote repo, which by default creates a new folder. Once I knew that the new repo was working, I deleted the old folder.

0

The standard trick for these kinds of problems on windows is to completely remove and reinstall the software in question.

If that doesn't help, according to this page folders can have different context menus based on their folder template.

Have a look at the "Folder Options" dialog for the working and non-working folders. Check for differences.

You might need to dive into the registry to see if the "shell extensions" in question have been disabled for some kind of folders.

4
  • I'm aware of the "standard trick", but I'm not uninstalling and reinstalling git. Folder options are the same for both folders. I have no idea where in the registry to look for something like that; I'm a Linux girl and registry hacks are way out of my scope of Windows knowledge. Any ideas?
    – EmmyS
    Commented Dec 3, 2013 at 22:50
  • My recent problems with context menus were solved by updating to the latest version of msys-git. BTW, the registry locations are mentioned on the first page that I linked to. But IMHO, I very much prefer FreeBSD and Linux. Much less of a black box and easier to troubleshoot. Commented Dec 4, 2013 at 23:51
  • Thanks. As I said, I DO prefer Linux and use it at home, but my company's web servers all run on IIS and we don't have a choice in our dev environment. So when you "updated" git, how does that work? Do you have to uninstall the original version first, or just run the new installer and it will take care of everything? I can't take any chances with things going wrong; we don't have much of an IT dept. and there's no one who'd be able to help me fix it.
    – EmmyS
    Commented Dec 5, 2013 at 15:08
  • Yes, you have to de-install the old version before installing the new one. IIRC the installer checks for an older version and either removes it or tells you to do that, I don't recall. In Git-1.8.3-preview20130601 the "cheetah plugin" that manages the context menus was broken. Version Git-1.8.4-preview20130916 works fine. Commented Dec 5, 2013 at 22:42
0

If you are coming here to get Ubuntu for Windows bash in context menu, it's simple as this registry file:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\SOFTWARE\Classes\Directory\Background\shell\Bash]
@="Open in Bash"

[HKEY_CURRENT_USER\SOFTWARE\Classes\Directory\Background\shell\Bash\command]
@="\"bash\""

There is no command line arguments to worry about, because bash starts in the working (mounted) directory.

Above only works for right clicks on empty area at the explorer window. (For a right clicking in a Folder item I haven't found a good way cause the working directory is not set there.)

0

For me only a re-installation helped. I couldn't find the Registry keys mentioned in the other post.

Git for Windows

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .