I have bought a new D-link Wi-Fi modem recently, and I have connected one Linux system through LAN and another system through Wi-Fi. I can't ping the host which is connected to the LAN from the Wi-Fi host, but if I connect both to LAN, that works fine. What settings do I need to change?


  1. I am trying using IP addresses.
  2. Please find the IP information below. I got this from the ifconfig command, by connecting both the LAN and Wi-Fi at the same time.

      eth0      Link encap:Ethernet  HWaddr 00:26:b9:00:31:23  
                inet addr:  Bcast:  Mask:
                inet6 addr: fe80::226:b9ff:fe00:3150/64 Scope:Link
                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
                RX packets:1001 errors:0 dropped:0 overruns:0 frame:0
                TX packets:1984 errors:0 dropped:0 overruns:0 carrier:0
                collisions:0 txqueuelen:1000 
                RX bytes:332948 (332.9 KB)  TX bytes:237770 (237.7 KB)
      wlan0     Link encap:Ethernet  HWaddr 00:24:d6:14:35:44  
                inet addr:  Bcast:  Mask:
                inet6 addr: fe80::224:d6ff:fe14:350a/64 Scope:Link
                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
                RX packets:8328 errors:0 dropped:0 overruns:0 frame:0
                TX packets:19806 errors:0 dropped:0 overruns:0 carrier:0
                collisions:0 txqueuelen:1000 
                RX bytes:2777900 (2.7 MB)  TX bytes:2298641 (2.2 MB)
  3. I am using DHCP only (not static).

  4. Even nmap is not showing the host  :(

    jeshwanth@jeshwanth:~$ nmap -sP 192.168.1.*
    Starting Nmap 5.21 ( http://nmap.org ) at 2013-12-03 23:31 IST
    Nmap scan report for
    Host is up (0.015s latency).
    Nmap scan report for
    Host is up (0.00081s latency).
    Nmap done: 256 IP addresses (2 hosts up) scanned in 16.02 seconds
  • 2
    Sounds like you have set up different subnets but we can't help unless you actually show us some settings. Are you pinging by hostname or by IP address? Please edit your question to answer this (do not answer in a comment) and also show us the settings of each connection, including the IP address, gateway and netmask. Also explain if you are assigning IP addresses automatically via DHCP or if they are static.
    – terdon
    Dec 3, 2013 at 17:38
  • 1
    Thanks for the edit, is the ifconfig output from the host that fails when connected by WiFi? Your nmpap output shows that the wifi IP ( is found. You seem to expect it to find 33, which machine is that?
    – terdon
    Dec 3, 2013 at 18:18
  • Yes the output is of the host (Wifi) which is trying to connect. 34 is my machine where I am executing nmap, 33 is may Raspberry pi :). And found the solution here superuser.com/questions/136031/ssh-no-route-to-host?rq=1 , I switched on "User Isolation". Its working fine now :). Thanks for your help :)
    – duslabo
    Dec 3, 2013 at 18:31
  • Could you post what you did as an answer and accept it when you get the chance?
    – terdon
    Dec 3, 2013 at 18:41

2 Answers 2


I have found solution in ssh - no route to host, what I did was, login to my modem (in my case through any browser). Select Advanced Tab, then go to wireless setting, In SSID settings changed User Isolation from off to on, restart the modem. Now you can ping/ssh to LAN connected host through Wifi connected host :).
I am using D-Link DSL-2750U Wireless N ADSL2+ 4-Port Wi-Fi Router

 Advanced >> Wireless Setting

  • Great!! Just the thing I have also been looking for!
    – L__
    Dec 21, 2014 at 15:06

I had a similar problem and a similar solution. I was connected via wireless Netgear on wlan0 where it would not ping the router even though dhclient worked (after dhclient -r).

I had to check the "Allow guest access to My Local Network" checkbox in my router (also Netgear). Then I could ping the router.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.