I am aware of this question: How to disable search in the Google Chrome address bar? and this one: Force Chrome to open URLs as URLs, instead of searching

However, both of those are about URL searches in the address bar so I don't think I'm asking the same question.

Anyway, when I go to www.google.com in Google Chrome and want to use the search box, which is in the middle of the screen, as soon as I start typing Chrome is forcing my search text into the address bar instead.

Under some circumstances I don't fully understand or can replicate reliably sometimes a search box appears just below the search bar instead (this is actually the default behavior in all other browsers I tested at www.google.com).

I think it is very "user-unfriendly" and a major design and usability flaw to move the text the user is typing to a different location while the user is typing the text. What I want is for my search text not to be moved to the address bar, or the search box itself to be moved as is the case with other browsers, while I'm typing.

Is there any way to achieve this while performing searches at www.google.com?

  • This only seems to happen to me when I open a new tab in Chrome. It shows the Google logo and the search bar as you describe, as if I'm really on google.com, but doesn't function the way google.com really does. I think that box on the other "google" page is linked through Chrome's Omnibox feature.
    – C-dizzle
    Commented Dec 3, 2013 at 21:31
  • Use CoolNovo. It has an option to change the omnibox into a separate address bar and a separate search box, but works almost exactly like Google Chrome.
    – gparyani
    Commented Sep 2, 2014 at 23:12

3 Answers 3


Dean. That's a misconception you have. That page you opened is actually the Chrome new tab page. If you set Google as your homepage and open it, there will be no problem. That place you wrote in is just an extension of the omnisearch bar.

  • That might be true, however, why even have the search textbox? Why does it jump to the top? If I make a new tab, I want to Google! I don't want my default homepage to be google because I want it to remember my tabs and I usually have 50 open at any one time. Commented Feb 7, 2020 at 13:50

I found a workaround. Change your default omnibox search engine to anything other than Google. Then the Google home page will operate normally.

  • This is actually no longer a solution; in newer versions of Chrome, changing the default search engine will completely remove the Google search bar from the new tab.
    – Gnemlock
    Commented Jan 18, 2019 at 0:14

Go to search settings and tick 'Never show instant results'. This stops the search bar moving to the top of the screen. For some reason, I have to do this every time I clear browser history, but it does work.

  • This option is not available in newer versions of Chrome.
    – Gnemlock
    Commented Jan 18, 2019 at 0:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .